URL Bar clears after a couple seconds, erasing my search

#1

When I open a new tab and start typing an address or search into the field, I only get a few characters in before it clears what I’ve typed. For example, if I open a new tab and start to type “How to bake sourdough”, by the time I’m done it will say “o bake sourdough”

This is on Windows 10, no themes or anything that is loading on the new tab.

#2

Happens to me to on Windows 7 as well. Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)

However, what I notice is that it doesn’t exactly delete, rather it selects the text written during the first few milliseconds and then as I continue typing, overwrites it.

Also, I’ve noticed sometimes it doesn’t happen immediately upon starting up Brave, only after awhile of use (not sure how long exactly), sometimes it doesn’t happen at all.

Also, I’m guessing it might be related to the new tab page loading. The new tab page doesn’t load instantaneously for me, it lags a few milliseconds (I approximate) before the wallpaper and stats show up, and as they show up, the overwrite happens.

I wanted to add a gif, but right now it’s not happening so I can’t record it. I’ll add a gif if/when it starts happening again.

#3

Well, said. That’s exactly what’s happening to me. Not a delete, but a text selection that is overwritten as I continue typing. Thank you.

I also agree with it being linked to the tab loading, which is why I mentioned I don’t have a theme set (as I thought maybe the tab would load, then the theme loading “deletes” the text.

#4

An example gif:

#5

Can confirm this behaviour on
OS: MacOS 10.14.3
Brave: Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)

#6

This seems to be a Chrome issue rather than something brave-specific.

There is an upstream bug report.