Urgent pls help! (dashboard not loading properly)

So I was going to do my homework and then suddenly upon launching brave this is what it said on the dashboard: "Aw Snap! Something went wrong while displaying this webpage Error code: RESULT_CODE_KILLED_BAD_MESSAGE ".
Was confused at first cuz i didnt even click anything that led to this.

Things i tried:

  1. under the said error text there was a learn more link. so i clicked it and then it led to a page about " How do I fix page crashes and other page loading errors?" it was some basic troubleshooting like check internet connection, clear cache Which I did all of. And its still the same. nothing changed.
  2. I search online about this. saw a yt video that said to change the dns so i changed it to and it did not resolve the issue
  3. saw a post on community.brave.com. the dude was facing a issue where it was completely blank had no text on it. Then one of the moderators told him to press f12 and paste this code: localStorage.clear(). But after pressing f12. I was greeted by this message on the inspect element page: “DevTools was disconnected from the page. Once page is reloaded, DevTools Will automatically reconnect” so i reloaded the dashboard and still it did not show the dashboard and the icons in it.
  4. I disabled all the extensions. It did not resolve the issue
  5. restarted my computer. again did not resolve the issue
  6. Restarted router. and check my wifi connection on my pc. I spent a good 30 minutes looking so definitely not a wifi/internet problem.
  7. Saw another post on Community.brave.com. said that close all other tabs. again did not resolve issue
  8. created another profile. did not resolve problem
  9. restarted all instances of brave. did not resolve problem
  10. went to settings → new tab page. on “new tab page shows” dashboard is selected

I am using brave for 1 year and 7 months now and this is the first time I have encountered problems with it. ALSO PLS DO HELP ME CUZ I HAVE A ASSIGNMENT DUE TODAY AT 10PM AND I ALREADY WASTED 5 HOURS OF MY TIME TRYING TO TROUBLESHOOT BRAVE.

@mattches @steeven look into this please. Thank you!

I have the exact same issue. Been going on for about a week or so.

@HELPMEPLS1 Just an FYI. Official support rarely is active on Brave Community on American holidays and weekends. With today being Saturday, you are likely to be waiting a couple days for a response. This is especially the case that you posted this topic at 3am (midnight pacific). Most likely any who do respond, such as myself right now, will be fellow Users and not people with Brave, at least until Monday.

I am going to ask you for some information you didn’t share, as it might help on which direction to go with things.

  • What OS and OS version are you using?

  • What version of Brave (can you navigate to About within settings to find out?)

  • Are you on a “regular” PC are you using something like a VM?

  • Have you tried manually updating the browser by going to https://brave.com/download/ and installing the latest, just in case yours was somehow corrupt?

  • Do all other websites work, with it just your dashboard that has issues?

@Saoiray Thanks for the heads up.

  • What OS and OS version are you using?
  • I’m using Windows 10 pro version 21H2(OS Build 19044.2251)(this info is from winver)
  • What version of Brave (can you navigate to About within settings to find out?)
  • After posting this, I tried to update brave to see if that would fix it. it still did not. Though here is the version: Version 1.46.134 Chromium: 108.0.5359.94 (Official Build) (64-bit)
  • Are you on a “regular” PC are you using something like a VM?
  • I’m using a Desktop PC. Hyper-V is enabled if that helps
  • Have you tried manually updating the browser by going to https://brave.com/download/ and installing the latest, just in case yours was somehow corrupt?
  • I did. I uninstalled brave through control panel then reinstalled and its still the same.
  • Do all other websites work, with it just your dashboard that has issues?
  • Well going to the sites I normally visit like youtube, google docs, Gmail all work. So its only the dashboard.

Things I Tried After Posting This.

  1. Saw another yt video. The instructions were to search “msconfig”, → services, click hide all microsoft services, apply then reboot, then reenable them again with the same steps(yt link: https://www.youtube.com/watch?v=5DePcMgVCQs) did not resolve issue
  2. Tried to run brave as administrator. Did not resolve issue
  3. on the page where it says aw snap, I clicked reload on the right of the message
    then it showed another error message . It says: Can’t open this page Try the following tips:
  • Open page in a new Private Window(Ctrl-shift-N). I dont understand the idea on why you should open a private window. But the private window does work(shows the usual brave logo with search box)
  • restart brave (I did restart brave)
  • restart computer (I did restart computer)
  1. saw an article online that said it might be a ram/memory issue. So I ran windows memory diagnostics. Still did not resolve problem
  2. uninstalled all extensions in case that was actually the problem. Did not resolve issue :frowning:
  3. Disabled and enabled Hardware acceleration. Did not resolve issue

same. seemed to happen after last update. now running this verion:
Version 1.46.134 Chromium: 108.0.5359.94 (Official Build) (64-bit)

The fact that it’s working a Private browsing window implies that there is something askew with your browser profile itself.

I know you said that you tried clearing your cache already but it definitely seems like a cache issue. Can you tell me what method you used to clear your cache when you did it?

my method for clearing cache – went to settings / privacy and security / clear browsing data / advanced, all time, with checks on cached images and files and site and shield settings. didn’t have any impact.
more info, when selecting new tab, takes forever before coming back with Aw Snap message.
Thnx for helping. Really aggravating not to have home page with most used sites

Does your OS have an option of like give option of clearing cache for each app ?
Like going to OS settings → Apps → Brave → Clear cache ?

I don’t think its a browser profile problem. Because I created another profile and it had the same issue of the dashboard not loading. So this suggests that its the whole browsers problem.

I believe this was the link I followed through to clear cache: https://support.brave.com/hc/en-us/articles/360048833872

I don’t see any option for clear cache. The options are only Modify(which is greyed out), or uninstall.

Apologies but I was confused about the actual issue you’re encountering. To be clear, you’re saying that the new tab page (shown below) is what is not loading for you?

Correct. As I said above, when I open a New Tab Page, Instead of viewing the usual dashboard(and icons), I instead see an error which is the “aw snap”. It actually makes the browser very inconvenient to use as I have to type the url(ex. youtube.com) then enter. I know that bookmarks exist but mine is filled with important links that I can pullup immediately when needed.

And it is only the NTP that is not appearing? Visiting other websites works just fine without any issue? And when you created a new browser profile, you still see this issue?

Also, after trying all that troubleshooting, have you changed all your settings (DNS, etc) back to their defaults?

I’m seeting the same thing as helpmepls. if newtab is set to dashboard or home page, throws “aw snap”. Only way SNT works is if set to blank page. I’ve tried uninstalling and getting a fresh download (with a reboot in between the uninstall and new install ) and reset all settings to default but dashboard is still broken.

also, same as helpmepls, tried new profile which did nothing.

@ngenana can you answer these three really quick. Curious to see if similar to OP or if have differences. They might ask more later, but kind of helpful to have these as a baseline.

Sure thing and hope this helps:

  1. Running Windows 10 version 21H2 (OS build 19044.2251)
  2. Brave version 1.46.134 Chromium 108.0.5359.94 official build 64-bit
  3. regular PC (very basic laptop)
1 Like


Not for Brave (not for most apps).
Using Windows 10. Per Microsoft: “most of the ones you installed have on the bottom. Modify…Uninstall…The ones with the most cache/data are those. If you click on modify it will redownload the app.”

I tried reinstalling Brave twice (and rebooted after the uninstall); didn’t have any effect.

I don’t know what you mean by “NTP”(google search shows “Network Time Protocol”). Visiting other websites does work fine. So its just the dashboard problem. After doing all the troubleshooting I did change all the settings back to their original options/values.