Updating Error- Update check failed to start (error code 3: 0x80070057 -- system level)

bug
#1

This happens in my last version of Brave as well as my current version.
I click on “About Brave” and I get the following message.

An error occurred while checking for updates: Update check failed to start (error code 3: [0x80070057] – system level).

Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit)

I am running Windows 7 Ultimate 64 bit.
I have tried turning User Account Control off and I still receive the same error.

#2

@Pyrran,
See if the solution here can help:

#3

I found that post and tried it. Here is the contents of the log file.

[03/11/19 11:33:57.511][BraveUpdate:goopdate][5444:8804][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /medsvc]
[03/11/19 11:33:57.524][BraveUpdate:goopdate][5444:8804][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[03/11/19 11:33:57.524][BraveUpdate:goopdate][5444:8804][is machine: 1]
[03/11/19 11:33:57.527][BraveUpdate:goopdate][5444:8804][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[03/11/19 11:33:57.587][BraveUpdate:goopdate][1428:9864][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /svc]
[03/11/19 11:33:57.594][BraveUpdate:goopdate][1428:9864][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[03/11/19 11:33:57.594][BraveUpdate:goopdate][1428:9864][is machine: 1]
[03/11/19 11:33:57.597][BraveUpdate:goopdate][1428:9864][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[03/11/19 11:33:57.739][BraveUpdate:goopdate][1428:9864][DllEntry exit][0x00000000]
[03/11/19 11:33:57.740][BraveUpdate:goopdate][5444:8804][DllEntry exit][0x00000000]
[03/11/19 11:34:01.629][BraveUpdate:goopdate][10720:7248][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /ondemand ]
[03/11/19 11:34:01.639][BraveUpdate:goopdate][10720:7248][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[03/11/19 11:34:01.640][BraveUpdate:goopdate][10720:7248][is machine: 1]
[03/11/19 11:34:01.644][BraveUpdate:goopdate][10720:7248][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[03/11/19 11:34:01.708][BraveUpdate:goopdate][1012:9696][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /svc]
[03/11/19 11:34:01.715][BraveUpdate:goopdate][1012:9696][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[03/11/19 11:34:01.715][BraveUpdate:goopdate][1012:9696][is machine: 1]
[03/11/19 11:34:01.718][BraveUpdate:goopdate][1012:9696][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[03/11/19 11:34:01.752][BraveUpdate:goopdate][10720:7248][DllEntry exit][0x00000000]
[03/11/19 11:34:01.753][BraveUpdate:goopdate][1012:9696][DllEntry exit][0x00000000]

#4

Have you rebooted you machine?

#5

I have and it made no difference.

#6

@Pyrran,
Can you try downloading the installer again and try running it - but don’t uninstall what you currently have. This way, the installer itself will substitute for the “updater” - let me know if this works for you.

#7

Just tried that. Brave installed over the original, ran the updater program and got the same error.
I’m going to try it over again with UAC off. Maybe that might make a difference?
I am running Trend Micro antivirus, but it knows to trust the installer.

UPDATE: Turned off UAC, turned off antivirus, reinstalled Bravo over initial installation.
Sadly, nothing changed. I still got the same error.

#8

Hmm, you might consider trying with Trend down if no other options work - Brave and AV software have not been playing nicely together. Definitely try with UAC off/running as Admin.

Optionally, we have offline installers that may work - problem might be accessing the files online. Download the standalone installer here:
https://github.com/brave/brave-browser/releases/tag/v0.60.48

#9

Also, are you using a VPN by chance?

#10

No, wired connection to the internet via Spectrum, using my own cable modem and my own wireless router. Tried installing using the standalone setup. Same results. Arg!
Also looked at the update services. Oddly, there are two of them. Brave and bravr, both described as update services. Of course, neither one will run manually without a remote procedure call, so my attempt to start one failed. I am at a loss as to what to do next.

#11

@Pyrran,
If you wouldn’t mind, I’d like you to try and download our Beta or Developer channel Brave installers and see if these install and update to the latest versions. They will not overwrite or interfere with any other Brave installation data already on your machine.
Links:
Brave Beta
Brave Developer

#12

Installed the developer and the beta version.
Clean installs on both, changed nothing. Went right to “About Brave”
Got the same error message on both versions.

An error occurred while checking for updates: Update check failed to start (error code 3: [0x80070057] system level).

1 Like
#13

@Pyrran,
I too am a bit confused about what’s happening here. My thought is that this is the fault of something external but that’s hard to confirm. You mentioned that you’d disabled UAC and your AV and attempted to install and got the same errors.
Are you running any other apps/programs (especially any related to network connections) while trying to install? And I assume you are installing Brave on a home computer/network - not a work computer or some other office network setup?

#14

You’re correct. Windows 7 Ultimate 64 bit home network, direct wired to the router.
I keep thinking it might have something to do with the update services themselves.
You can’t run them manually (at least I haven’t been able to) because they rely on a remote procedure call. There are two Brave update services in my list of services. Is that correct? Should both be there? One shows up as Brave and one as Bravem.

I will try disabling everything running TSR, including UAC and Trend, then reinstall the beta and the developer versions and see what happens. Will let you know and by the way, thanks for sticking with this!

1 Like
#15

No problem at all – always like a good mystery :slight_smile:

I’m sure you’ve checked this right now but is Windows [firewall] enabled?

#16

Yes, but I allowed all Brave browsers through the firewall. Sadly, no luck there.
I’ll let you know how the rest of my plan goes.
By the way, has anyone else had this problem using Windows?

#17

Ok, I’ve officially given up.

  1. Tried uninstalling everything, then reinstalling, nope
  2. Tried turning off AV and UAC, nope.
  3. Tried installing beta and dev versions, nope.
    And here’s the kicker. I have another computer, Win 7, same AV, same setup with UAC, same version of Windows, same network connection, and the update works just fine!

I am completely out of ideas at this point. Let me say that I really appreciate the time you’ve put in on this and it’s too bad we weren’t able to figure out the problems.

closed #18

This topic was automatically closed after 30 days. New replies are no longer allowed.