Error with Brave Update

bug

#1

Hi Guys,

I need a little help here. I have had the chromium Brave since release. I have yet to receive an update. When I go check for the updates I am greeted with this message " An error occurred while checking for updates: Update check failed to start (error code 3: 0x80040154)." I have uninstalled and re-installed Brave. I am now on the latest version. However, this message still appears. Any help please.


#2

@talb1, apologies for the late response.
Not sure I’ve seen this error before, but I have seen similar reports.
First, can you tell me which operating system you’re using? Is it Windows 7?
What version are you currently running that you’re unable to update from?

Also, would you mind providing a screenshot of the error as it appears?


#3

I’m on windows 10.
I’m on version “Version 0.56.15 Chromium: 70.0.3538.110 (Official Build) (64-bit)”
I was on a different version before I uninstalled and re-installed


#4

Perhaps I’m confused?
The version you’re using is the most up-to-date stable release right now.


#5

Yes, but only because I uninstalled Brave, and re-installed it from the website.


#6

Hi,

i can confirm that there is a error when trying to update the browser; i just installed Brave browser today (version 0.56.15 Chromium: 70.0.3538.110 64bit) but when i try to update i get the following error message
An error occurred while checking for updates: Update check failed to start (error code 3: 0x80004002 – system level).

Greetings


#7

Looking into this now, can you please tell me which OS you’re using?
@Fenris


#8

Thanks, I’m using Windows 7 Home Premium Service Pack 1 64bit


#9

@Fenris @talb1,
This has actually happened before.

We’re going to attempt to fix the issue and/or diagnose it using the same steps. Fun right? If you’re willing, try the following (Note: there isn’t any sensitive or private info displayed in the logs we’re about to request):
For Windows OS

  1. Navigate to your C: drive
  2. Create a file called BraveUpdate.ini and save it there:
  3. Insert the following text into the BraveUpdate.ini file:
[LoggingLevel]
LC_CORE=5
LC_NET=4
LC_PLUGIN=3
LC_SERVICE=3
LC_SETUP=3
LC_SHELL=3
LC_UTIL=3

LC_OPT=3
LC_REPORT=3

[LoggingSettings]
EnableLogging=1
LogFilePath="C:\BraveUpdate.log"
MaxLogFileSize=10000000

ShowTime=1
LogToFile=1
AppendToFile=1
LogToStdOut=0
LogToOutputDebug=1

[DebugSettings]
SkipServerReport=1
NoSendDumpToServer=1
NoSendStackToServer=1
  1. Launch Brave (which ever build you’re attempting to update) and attempt the update again.

There is a chance that this alone will resolve the issue. However, if it does not, it will produce a log file in the C: drive (BraveUpdate.log iirc). Send me the contents of this log file and I can have the team attempt to diagnose the issue.

Let me know if you need additional help or if any of this is unclear.


#10

Thanks for the fast reply; i did that but i’m getting the same error. I can’t attach the log so i paste it here

[12/07/18 21:29:20.587][BraveUpdate:goopdate][24340:26752][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /broker ]
[12/07/18 21:29:20.589][BraveUpdate:goopdate][24340:26752][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[12/07/18 21:29:20.590][BraveUpdate:goopdate][24340:26752][is machine: 1]
[12/07/18 21:29:20.591][BraveUpdate:goopdate][24340:26752][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[12/07/18 21:29:20.651][BraveUpdate:goopdate][26932:14280][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /medsvc]
[12/07/18 21:29:20.654][BraveUpdate:goopdate][26932:14280][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[12/07/18 21:29:20.654][BraveUpdate:goopdate][26932:14280][is machine: 1]
[12/07/18 21:29:20.655][BraveUpdate:goopdate][26932:14280][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[12/07/18 21:29:20.716][BraveUpdate:goopdate][21528:15008][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /svc]
[12/07/18 21:29:20.718][BraveUpdate:goopdate][21528:15008][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[12/07/18 21:29:20.719][BraveUpdate:goopdate][21528:15008][is machine: 1]
[12/07/18 21:29:20.720][BraveUpdate:goopdate][21528:15008][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[12/07/18 21:29:20.838][BraveUpdate:goopdate][21528:15008][DllEntry exit][0x00000000]
[12/07/18 21:29:20.838][BraveUpdate:goopdate][26932:14280][DllEntry exit][0x00000000]
[12/07/18 21:29:20.889][BraveUpdate:goopdate][13484:26620][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /svc]
[12/07/18 21:29:20.892][BraveUpdate:goopdate][13484:26620][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[12/07/18 21:29:20.893][BraveUpdate:goopdate][13484:26620][is machine: 1]
[12/07/18 21:29:20.894][BraveUpdate:goopdate][13484:26620][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[12/07/18 21:29:20.905][BraveUpdate:goopdate][24340:26752][DllEntry exit][0x00000000]
[12/07/18 21:29:20.906][BraveUpdate:goopdate][13484:26620][DllEntry exit][0x00000000]


#11

I have tried everything. Honestly, at the end of the day. I am so close to just uninstalling Brave and moving on with my life.


#12

I have tried this. I still get the same problem.


#13

@talb1,
As I stated above,

This was not guaranteed to resolve the issue, but we’ve had it do so in the past. If it didn’t work for you, the log information will help us get to the root of the issue.


#14

I have tried this. It does not create a log of any type.


#15

Did you attempt to update again after adding the file above?
Where are you looking for the log file?