Unsure if Widevine issue or my browser

Unable to access any content on streaming sites such as Netflix, Prime Video, or Spotify Web player, basically anything with protected content.

I have tried everything listed on these forums and on reddit. I have tried:

  • Disabling then re-enabling widevine, installing when prompted by sites
  • Shields up (standard and aggressive blocking) as well as shields fully down
  • On a brand new profile
  • On a private browser
  • Downloaded Brave again on top of my current browser (no uninstalling)
  • Tried using Brave Beta, still blocked

I can stream videos just find when I use Microsoft Edge, I am running on Brave v.1.61.114 Chromium: 120.0.6099.199

When I check components, widevine says up to date and shows this version: Widevine Content Decryption Module - Version: 4.10.2710.0
I am running on Windows 11,

I have also tried disabling any extra extensions I have downloaded such as Honey or Google Translate in case they interfere, to no luck. I am not tech savvy at all and have no clue how to fix this, apologies and please be patient with me as I try and get any more info needed!

I also want to thank @Saoiray who was helping me on reddit (most of the troubleshooting tips were from him!) and pointed me over here to the forums!

1 Like

@Mattches @steeven would either of you have ideas on what might be happening or what to try?

1 Like

@scramble,
Thank you for the detailed report. If I’m being honest, I have no idea why this would be happening, especially if it’s working on Edge.

When you go to stream something (on Netflix for example), what exactly happens? Is there an error message displayed on Netflix or is it just a black screen? Further, it might be helpful to get some console data — please try the following (I’m assuming that the site loads and you’re able to at least attempt to stream a video. If this is not the case let me know):

  1. Visit Netflix.com
  2. Select your profile, then once the site loads, go to Menu --> More Tools --> Developer tools
  3. This will open another window/pane in the browser — make sure the Console tab is set in this new pane.
  4. Now click and attempt to stream a video on Netflix

Take a screenshot (or copy and paste) of the output shown in the Console with us here.

Thank you

1 Like

The image on the left will pop up no matter what content I watch on Netflix

image
Sorry for double post, forgot to add this on if it could be important!

@scramble,
Thank you for the information.

Looking into this for you

1 Like

Thank you so much for this! <3

@scramble,
Can you please share a screenshot of what your brave://settings/content/protectedContent page looks like? You can just take a screenshot of the whole page, thank you.

I also wanna add I have tried manially adding streaming sites to the allowed section and that failed to work in the past.

Thank you for the information.
Still unclear as to why this is happening — asking some devs for more information. Will reply back here shortly.

Thank you so much again for all the help so far!

@scramble,
Just checking back in to let you know we’re still digging on this. Appreciate your patience.

@scramble,
Just to triple-quadruple check, you do see the Widevine toggled “on” in Settings --> Extensions, correct?

@scramble
If the above is true, can you please try disabling that toggle, then closing the browser and in Windows, go to

C:\Users\[your user name]\AppData\Local\BraveSoftware\Brave-Browser\User Data\WidevineCdm

and delete this folder (the WidevineCDM folder). Then, revisit Netflix (or any DRM required site) and allow/enable Widevine when prompted. This will re-fetch the component and will tell us if the component is the issue here (note that the error you’re seeing on Netflix — M7702-1003 is listed as a widevine component issue).

Thank you

Followed all steps you gave, Netflix is still blocked :frowning: Hopefully this helps solving the case! Thank you!

1 Like

I am a Firefox user. I could not use spotify web on one of my profiles, but it worked on the other. I swapped the drm folder from the working profile to the broken one, and voila. But then, I checked their hashes, and they were the same! In other words, I’m completely confused, but it’s working now.

I tried a new profile and it didn’t work still :frowning: So I still feel very lost lol

I was struggling with this same issue since the January update. Decided to look again today, wondering if there was any fix yet, and came upon this post. Went through all the suggested steps, no joy. Then another page/site suggested turning off Brave Shield, and it worked. I can once again play DRM content on sites. I no longer need two browsers. Don’t know if it will help you, but thought I would pass it along.