Netflix and Widevine


Description of the issue:
I updated Brave browser and now Netflix isn’t working because of Widevine. I’ve already tried previously discussed solutions on this forum, including disabling it on extension tab and restart brave, so when I enter Netflix the Brave Browser asks if I want to use Widevine. I gave permission but it still isn’t working.

How can this issue be reproduced?

  1. I installed Brave 1.21.73
  2. Opened Netflix and it isn’t working.

Expected result:
I’m not sure how to answer that. I guess Netflix should be working, right?

Brave Version( check About Brave):
1.21.73

Additional Information:
N/A

@HodlerHedler,
Thank you for reaching out.
Can you please be more specific about what you mean when you say it “isn’t working”? Does the site not render at all? Does it timeout? Are there error messages displayed? Is it explicitly telling you that Widevine is the issue?

Thank you for your reply! I got Error M7121-1331.

EDIT: I guess I should have been more to the point and just told I got this error. I just assumed that was related to Widevine. My bad.

1 Like

@HodlerHedler,
No worries, thanks for confirming.
So what I’d like you to try, if you’re willing, is to create a temporary new browser profile and attempt to visit/login/watch Netflix using that new profile. Ensure that when you test, the Brave window with the new profile is the only Brave window open.

If it’s a Widevine issue, you’ll likely be prompted to install it/enable it when you land on the site. If you are, please do so and ensure that it worked. Now return to your old/original profile and see if you get different results.

I created a new user and closed Brave. Then opened the browser with the newly created user. Once I logged on Netflix I was prompted to enable Widevine. I did so but the same error is displayed everytime I try to watch something.

1 Like

@HodlerHedler,
And this is in the new profile that you see the error? That’s very strange. Are you connected to a VPN of any kind?

I just created another user profile, just to check if I didn’t screw up the first time. I was not prompted to allow Widevine, but still geting the same M7121-1331 error (in the test user profile, yes).

I don’t use any VPN.

I don’t know if this is relevant, but Netflix was working like a charm yesterday. The issue only began after I installed Brave 1.21.73 (using the BraveBrowserSetup.exe file). Of course I only noticed after I tried watching Netflix.

EDIT: To be clear, I updated Brave running BraveBrowserSetup.exe.

1 Like

@HodlerHedler,
Yeah 1.21.73 seems to have caused several strange issues. I’m going to ask the team and see if anyone has additional input.

In the interim, can you try testing any other sites that require Widevine and see if those work? I realize you may not have accounts for any of them, but if you do please test for me as it will tell us a lot. Other than Netflix, other sites that require Widevine include:

  • Spotify
  • Disney+
  • Hulu
  • Amazon Prime Video
  • BBC
1 Like

My brother has a Spotify account, I’ll try to check the other ones too. Hope you guys solve this, Brave is awesome!

EDIT: Spotify seems to be really weird. The player reproduce some seconds of a song and then it goes silent and time freezes.

1 Like

Here is Amazon Prime:

@HodlerHedler,
Can you please go to brave://components and find the Widevine Decryption Module and tell me what version it shows? If updated to latest, it should read

Widevine Content Decryption Module - Version: 4.10.1610.0
1 Like

Here is what it says:

image

I clicked to check updates, now it says:

image

@HodlerHedler,
Thank you for the information.
I’m looking into this now and will reply when I have more info. I do appreciate your patience

1 Like

Hi,

I am currently experiencing the same issue. My Widewine Content Decryption Module version below.

Widevine Content Decryption Module - Version: 4.10.1610.0
Status - Up-to-date

I’m using the following version of Brave running on Ubuntu 18.04.5 LTS.

Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (64-bit)

Let me know if you need any additional info.

Nas

1 Like

i’m also facing the same issue, installed the latest version of brave on my macbook and when i try log in to netflix i get incorrect password. has there there been and fix for this yet

@fungainengare,
That is not the same issue as what’s being discussed here. Please open your own thread and include any information relevant to your issue and we’ll be happy to help you.

Thank you.

my apologies. let me do that.

1 Like

Having the same issue here but my case it might be because I declined to install Widevine, is it mandatory to have it installed to be able to watch Netflix, Prime, Hulu?
Don’t like Google stuff on my computer.

@lflucena,
Yes, unfortunately at this time, Widevine is required to watch protected content.

Just want to let everyone know we’re still digging into this.

1 Like

Hello,

Just wanted to say that Netflix seems to be working fine in Brave 1.22.67

1 Like