Unable to disable tab cycle with mouse middle button scroll on Linux

For a very long time as far as my brief research went, Brave has had this “feature” to cycle through tabs with the mouse middle button scroll. However, I can’t seem to find a way to disable this “feature” and, as far as I could find, there simply is no way to do so.
This behaviour is highly undesirable, to the point I’m considering leaving Brave exclusively because of this. For people who, like me, have a very sensitive mouse scroll, cycling through tabs by accident is the norm.
Note that this only happens on Linux (idk about MacOS though).
I believe it is on every Linux users best interest to have a way to disable this “feature”, ideally by default.

1 Like

It is very annoying. It does not happen on Windows either, hopefully there is a fix for this. Happens on Linux Manjaro for me.

1 Like

Interesting. I never noticed this behavior.

I use ‘Enabled, shrink to medium width’ in brave://flags/#scrollable-tabstrip which I think is a great setting regardless, and it also appears to disable the behavior you’re complaining about.

Maybe give that a try? Seems like a ‘best of both worlds’ to me, although YMMV.

I should add that if you have a ton of tabs open it will ‘scroll’ the strip (that’s the point of the flag), but it will not change the tab that you’re looking at when this is enabled, which I think is your chief grief.

Hello brother, do you know why notifications of announcements do not arrive? were they removed? only image views can I charge puedes ayudarme?

Thanks for the answer, however on my end disabling this feature did not actually disable tab scrolling :frowning: