Please disable "Scroll Over Tabs" feature

Currently, Chromium on Linux has no way to disable the dreaded “Scroll Over Tabs” feature. As a result, multiple times per day (usually when very busy), I will inadvertently slightly touch my trackpad while the cursor is over the tab area and as a result Brave will scroll through all my open tabs landing me on one which I did not intend.

This is a serious workflow impediment (its really a poorly thought out “feature” – especially in the days of touchpads).

If you read any of the chromium discussion sites you will find long threads on users asking for how to remove this). For Windows users, Chromium has offered a way out: https://code.google.com/p/chromium/issues/detail?id=1316

However, sadly for Linux users the only way out is recompile commenting out this line: “g_signal_connect(G_OBJECT(container_), “scroll-event”, G_CALLBACK(OnScroll), this);”

See discussion here on this topic:

Please consider doing this. Brave is my daily driver and it is very frustrating to constantly have tabs jump around randomly because of the slightest two-finger brush when hovering near tab area.

Its a simple request to comment-out the offending line. Shouldn’t take more than 10 mins max :slight_smile:

Please delete the text above the line before posting


1 Like

Actually, I noticed this last night too. It took me a minute to figure out what was happening.

I actually love the feature and actively searched out an add-on for FF when I was using that.
I can see how it would be frustrating if you are not used to it.
An option to disable the feature would be handy, but please don’t remove the feature, because to some it IS useful.
Thanks.

I am failing to understand why this behavior is forced. If it was just another option to be disabled I could at least understand. But forcing people to use this “feature” is abysmal! This “feature” sadly hinders my workflow.