Trouble Launching the new Brave [Core]

description of the issue:
I’m trying to start using the new Brave

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  • I have downloaded and installed the new Brave Browser.
  • On the old version on ‘new tab’ the instruction is to launch the new brave.
  • The text says ‘Installed version: 0.62.51’.
  • When I click the button on the ‘launch the new Brave’ on the new tab, or that button at the top of the browser, another Brave window does come up, but it is white, with nothing happening, or, it is black, with nothing happening.

Actual Result (gifs and screenshots are welcome!):

  • It’s a black or white screen - I have retried many times, have powered down and restarted the desktop since installing the new version.

Expected result:

  • The new Brave browser will come up and there is a welcome tour which will show me how to transfer my data from Muon to the new Brave ‘Core’

Reproduces how often:

  • that’s what it does again and again

Operating System and Brave Version(See the About Brave page in the main menu):

  • Windows 7 - desktop 64bit

Additional Information:

  • I did look for answers for this problem in all the forums, support and community and found this type of thread to date back to last year and February and those threads were closed.

  • This scenario happened last time I tried to update - get a new version of Brave, but I sorted it then, can’t remember when that was and how I sorted it.

replying to my own post to say: I wasn’t logged in when I was looking through the forums to find the topic so I don’t know how long that took.

Apologies for late response and welcome to the Community @Dryad.

Can you try:

  1. Find the shortcut for Brave 0.62.x (generally on Desktop), right-click and select Properties from the context menu.
  2. Click into the “Target” field, and type --disable-gpu at the end of the path. Note that you must type this outside of the quotes with a space between the flag and quotes. It should look something like this:
  3. Click Apply then OK then open the modified shortcut you just created.
  4. Assuming this worked and you’re able to view Brave, open the main menu on the top-right
  5. Navigate to Settings --> Advanced --> System --> Hardware Acceleration
  6. Ensure this option is off. If not, toggle it off and relaunch:
  7. Now, return to the modified shortcut, remove the --disable-gpu flag from the Target path and launch Brave using that shortcut.


1 Like

Thanks for the welcome eljuno.
I expected to wait for a reply so no worries. Still got 7 days to sort it . . …
I do like using Brave so I am grateful for the detailed response.
I’m going to copy the instructions, tomorrow I’ll follow them with a clear head.
I’ll hopefully confirm success then, or report back with a follow up query.


Hello eljuno, community

. . . it took me a while to get to steps as directed [IT partial wimp].

  • It seems your instructions have worked with my set up and the Brave Core 0.62 appears to have launched. [phew.]
  • Took me a while to find the main menu on the top-right - how dense can a person be???

Screen shot of this thread, attached, showing that the new browser does bring up an url.

Thank you very much until next time.
I do hope this thread will help others who have had trouble with the same issue.


1 Like

Oh, and . . .
At the link below the article states :
’ 3. After completing the installation process the new Brave will launch and you will be greeted with the Welcome Tour.’

I was not greeted with the welcome tour.
I will scout around to see if there is a button by which to launch the tour.

@Dryad glad to know its works for you. :slightly_smiling_face:

If you not see the welcome tour, you can type brave://welcome in URL bar.

1 Like

Done the welcome tour now eljuno, thanks. :sunglasses:

Think all I’ve got left to do on this topic is uninstall Muon. I’m probably researched enough now to try that properly.


This topic was automatically closed after 30 days. New replies are no longer allowed.