Tor Browser bug?

hello, I have been trying to connect to some .onion chatrooms, but they all seem to have a problem. the websites’ url load, but the site doesn’t work properly. All I see is a blank page in some chatrooms, and for another one I can see the page but can’t interact or send any messages.

I have had this problem for a while, but before I was able to connect and use them without any issues. Other websites, search engines and html websites work fine, and the problem is only for the chatrooms. Also the chatrooms work fine for others, but not for me.

I tried enabling and disabling “block scripts” but that doesn’t fix it. Does anyone have any idea how I can fix the issue?

@JustRandomly Sorry for the late reply, just now noticed your topic. Let me ask, I noticed you mentioned toggling Block Scripts but you didn’t mention anything about other Shields settings. What do you have things like Block Fingerprinting set to? Often if it’s set to Strict, it can break content like you’re trying to access. So just kind of curious if that might be the issue there. Of course, other question I would ask is if turning off Shields might cause it to work. I’m not suggesting to leave Shields down permanently or anything, but just to check if it’s indeed what is causing the issue or if it’s something else.

Thank you for your reply. I had to double check my settings, and disabled fingerprinting, cookies, trackers and shields but the problem is still there.

I just checked the link with the tor browser, and only the tor connection in Brave doesn’t work. I still would like to continue with Brave if the problem get fixed.
If you know, please let me know if you have any other questions and other settings I should change.

Thanks!

Hmm, let me tag @fanboynz and @Mattches. I’m not really familiar with the Tor aspect and am not sure what info might be needed. What I will say though, @JustRandomly, it is might help if you can provide info as below:

  • Which OS?

  • Which version of Brave?

  • Link(s) to some of the chats/sites you experience issues.

Alright, I tried the links with two OSs and both had the same issue.

Windows Brave version 1.50.121
Mac Brave version 1.50.119

Links that I have issues:

dkforestseeaaq2dqz2uflmlsybvnq2irzn4ygyvu53oazyorednviid.onion
blkhatjxlrvc5aevqzz5t6kxldayog6jlx5h7glnu44euzongl4fh5ad.onion

@JustRandomly,
Tested on my end — was not able to get into the second link (waited forever to be let in the room by mod but that never happened). Did login to the first one and also saw the behavior you’re seeing as well. I thought it had something to do with HTTPS being enforced by Brave’s Shields but it seems that disabling HTTPS (and Shields in general) did not make any difference.

Reaching out to some team members to take a look.

@JustRandomly,
Looks like we have logged this issue:

Checking with the team to see if we can get some additional eyes on this.

2 Likes

Thanks, hope it get fixed.

@JustRandomly looks like they might actually be getting movement on it. I just checked the Github that Mattches linked to and one of the developers self assigned to it. Then they opened a new Github issue at https://github.com/brave/brave-core/pull/18325

If I’m seeing that right, it appears like they might actually be nearing completion on that already. But we’ll just have to keep an eye out to see.

Alright thanks for letting me know! I will keep an eye on it.

Wow, I thought I had seen every type of captcha that exists. But then I just went to test the onion sites listed and found one that took me forever to get right.

Tor Browser bug_ - Misc _ Private Tabs with Tor - Brave Community - Brave 5_3_2023 15_52_12

It’s ridiculous! lol. And yeah, I also learned how dumb I am as I’m seeing people talk about things like their PGP Key and all, which I have no knowledge about. I really need to educate myself on stuff like that.

Anyway, I had been hoping based on what @Mattches mentioned that it was just about the whole “secure origins” thing. So I had tried changing the flag for it under brave://flags, thinking that disabling HTTPS-Only Mode in Private Windows with Tor might make it work. But nope, same issue as you…

I mean, you can click to read all messages and see what’s been said. But nothing is loading to where you can type.

Mattches, just tagged you in because wanted to confirm if it’s what you’ve already seen and acknowledged or if it’s two different issues.

1 Like

Hahaha yep… everyone have the same issue with the captcha when they join for the first time.

There you always learn something new. Hope you don’t get addicted like me :sweat_smile:

You might want to review Tor Browser’s security settings, clear cookies and cache, and ensure JavaScript is enabled.

1 Like