Thunderbird incoming email links won't open in Brave

Description of the issue:
After a recent update to Brave, it will no longer open tabs for links when I click on them in incoming Thunderbird email. Brave is set as my default browser and set as the browser in Thunderbird.

If I change my default browser to either Firefox or Chrome then they open just fine.

I have the latest versions of both Thunderbird and Brave.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Verify in Windows Default Apps setting that Brave is the default browser
  2. Set Brave as the desired browser in Thunderbird Options-> General
  3. Click a link in an incoming email.

This also does not work when trying open Help using F1 or the menu option, as the help opens in a browser page.

Actual Result (gifs and screenshots are welcome!):
Nothing happens when Brave is set up as the target. There are no error messages.

Expected result:
The requested web page should open.

Reproduces how often:
This happens every time I click a link. If I copy the link and paste it in Brave, it works fine.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10, current version. Brave version 1.24.86

Additional Information:

@HJSage,
Thank you for reaching out.
So when you say

Did you go to the Config editor and change the network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https values to True?

I did not. Where will I find the Config editor?

@HJSage,
You can follow the instructions here:

Note that in the above article, it directs you to go to Edit --> Preferences but what they mean is (in Thunderbird) go to Tools --> Options. Simply type in Config editor in the search box on the Options page and you’ll see it appear. Follow the rest of the steps to set Thunderbird to use external browser when clicking on HTTP/HTTPS links in emails.

I made this change. I now get a warning popup to which I select to follow the link. Still doesn’t make it to Brave.

Note that I had no problem getting to Chrome and Firefox, but (of course) I prefer to go to Brave.

@HJSage,
Apologies – what warning pop-up are you referring to? Can you send a screenshot (note that you can copy/paste images directly into the editor here on the forum)?

The config parameters tell Thunderbird to warn when going to an external http/https. When I click a link, it pops up telling me it will go to Brave and allows me to pick another browser. I left it as Brave and told it to continue.

@HJSage,
And then what happens after telling it to open in Brave? Nothing?

correct, nothing happens

That’s quite strange.
I just downloaded Thunderbird and tested this on my end following the same steps and was able to get Brave to launch when clicking on an external link.

This may seem silly, but on Windows, can you try removing Brave as the default browser application, and then just re-adding it and see if this makes any difference?

I just did while you were typing. I changed the default browser from Brave to Firefox. Didn’t need to change anything in T-Bird, and it opened in FF.

I will try this on my laptop (I’m on a desktop now) and see if it is the same. If it works, I will try reinstalling first T-bird and, if needed, Brave.

1 Like

@HJSage,
Let me know after reinstalling Thunderbird (before uninstalling Brave).
I don’t see any open issues that describe this either. It’s also strange that this works fine with opening links in Chrome as it should definitely work in Brave if that is the case.

A) This works fine on my laptop

B) After reinstalling Thunderbird on my desktop, the problem still exists. I should add that the configuration was reused as well as all mail that had been downloaded. I did not have to redo anything.

C) I have tried with two different email accounts from different providers and get the same results.

1 Like

Apologies for the long wait. Still unclear why this is happening – I’ve reached out to some colleagues for some additional eyes on the situation.

Appreciate your patience with us.

And I appreciate your attention to this.

1 Like

Hi @HJSage

I was going to recommend trying older versions of Brave to see if they made a difference, but you had shared the same version on your laptop is working fine

Do you have a way (on the machine having this problem) to:

  • Close Thunderbird
  • Rename your Thunderbird profile folder (ex: put a 2 at the end). You can check this article to see where the profile directory is (should be under %APPDATA%)
  • Launch Firebird fresh
  • Try adding an email so you can launch a link

If this works, then it’s gotta be a problem with the profile. You can then close out Thunderbird and save this working profile somewhere. Then rename your real one (ex: one you put a 2 on) to restore your real profile.

You might search the profile directory for a file called mimeTypes.rdf. You can back this up and copy the version from the working profile on top of the not working one. I suspect something came up here specifically about handling Brave and maybe it’s corrupt