Hyperlinks from email don't work after Windows update

Description of the issue:

Until today, hyperlinks in Thunderbird email messages worked fine. Clicking a link caused the page to be opened in Brave, my default browser. Last night, Windows updated itself to Windows 10, version 20H2, and hyperlinks no longer work. Nothing else changed. Brave was still set as the Windows default.
I went through the Thunderbird troubleshooting steps here


but nothing helped.

How can this issue be reproduced?

  1. Update to Windows 10, version 20H2,
  2. With Brave set to be the default browser, open Thunderbird (or possibly some other email client).
  3. Click on a link in an email message.
  4. Observe that nothing happens.

Expected result:

The web page should open in Brave.

Brave Version( check About Brave):

Version 1.18.78 Chromium: 87.0.4280.141 (Official Build) (64-bit)

Additional Information:

In the Thunderbird Community, someone suggested changing my default browser to Edge and then back. I performed the following experiments:

I used the Windows settings to change the default browser to Edge, then clicked on a link in an email message. Edge popped up with the web page. Edge was not previously running. With Edge still running, I clicked another link. The web page appeared in a new Edge window, not in a new tab.

Next, I set the default back to Brave,. Clicking on a link in email did not work. (Nothing happened.)

Next, I set the default browser to Firefox, which was already running. I clicked on a link, and got an error message saying Firefox was already running and did I want to close it first. Apparently, Windows tried to run a new copy of Firefox.

Next, I set the default to Chrome, which was not running, and clicked a link in email. Chrome popped up with the web page. Keeping Chrome open, I clicked on another link, and it opened in a new tab. I used Chrome Version 87.0.4280.141 (Official Build) (64-bit). Notice this is the same version of Chrome that is the Brave base.

So it seems Windows has changed the way it passes links to the default browser, and different browsers respond differently. If I’m correct, it would not be the first time Windows broke an interface.

It seems odd that Brave unfortunately does not behave like Chrome in this case.