The block auto-play option is not blocking videos from automatically playing anymore | also the "Switch to this tab" button isn't working all the time

Hi, the feature to block auto-play on websites with videos is not working anymore, especially on youtube. Had blocked ‘autoplay’ for youtube, but all the videos are now automatically playing when opening / reopening the browser tabs / windows right after clicking on the window.

YouTube Site Settings: brave://settings/content/siteDetails?site=https%3A%2F%2Fwww.youtube.com

Also, when typing in a URL into the address bar that’s already open in another tab/window, there’s a “Switch to this tab” button at the far right of the suggestions that pop-up. That doesn’t work all the time consistently. Sometimes it works properly, and other times it doesn’t, just opens the URL in the current tab.

Thank you.

There was no template that appeared in the editor when I started writing it.

Please repost to reflect the template and guidelines and we’d be more than happy to assist you.

@life777eternal,
Can you try clearing your cache/browsing data for Youtube, then revisiting and setting the Autoplay permission to Block and see if this works as intended? Additionally, the Switch to this tab option only works if you already have that tab open in a different window (or the same window). It won’t appear if you’re visiting this site for the first time (during the current session).

Aye, I cleared the cache for the site by right-clicking on the page and selected “Inspect” and then right clicked on the reload button, and hit “Empty Cache and Hard Reload” Still no change, the auto-play was still not blocked. Also when I tried to change the setting for auto-play in the settings for the site, it kept resetting to block.

Aye, I know the “Switch to This Tab” option only works when the site is already open. For me it keeps changing, sometimes works and sometimes doesn’t work. That is that it opens the site in the current tab, instead of switching to the tab that it’s already open in.

Thank you.

@life777eternal,
So if you’re on YT and you hit the “lock” icon in the address bar and change the Autoplay permission to Block and refresh the page, videos on the page will still autoplay?

Same here, did all the same procedures, blocking is enabled through the site settings but YT still auto plays.

Brave Stable 1.14.81
Windows 7
MX Linux 19.2_KDE_x64 | Kernel 5.6.0-2

(I know this is for windows but just to let you know it’s happening across the board for me)

1 Like

Aye, @Mattches though after I click on the 'Lock' icon I have to hit "Site Settings" to get to the "Autoplay" permission. I’ve changed it to Allow, and reloaded the page, and then changed it back to "Ask (Default)/Blocked" … and when I reload the page again the video still automatically plays.

Also if I select "Ask (default)" beside "Autoplay" it automatically changes to "Blocked"

“Brave is up to date
Version 1.14.81 Chromium: 85.0.4183.102 (Official Build) (64-bit)

Windows 7 Service Pack 1 (they never did release any “Service Pack 2”)

We have a related issue report regarding autoplay. Added some details regarding youtube, which I could replicate.