Auto Play block DOES NOT WORK

So, I run Brave on Apple OS. Anyways, one of the big features is controlling what websites do what…

I turn auto play off, and it immediately turns back on. This is never ending and has been going on for two weeks at least, as long as I’ve had it.

Jalopnik.com is the biggest issue since they force videos non-stop.

Why does my autoplay button reset itself literally right after I click to block auto play. You click the button to stop autoplay, it kicks me back to main setting then I look and autoplay is allowed again.

WTF is going on. I am not a tech guy, I don’t code, so please try to help me in basic terms.

@Stupidhelpcenter,
I was able to visit the site and block Autoplay successfully when prompted to do so. If you click the “lock” icon in the address bar, do you see the Autoplay = Blocked reflected?

Hey @Mattches

Thanks for the response and yes it is blocked there. It does work sometimes but I find it inconsistent. One day it works, then the next it doesn’t.

Is there something I may be doing that is resetting things? Does closing the browser do so?

@Stupidhelpcenter,
Yes – when you clear cache/site data, permissions may also be reset for the site.

I have not cleared any data or cache. The settings are all still on, and multiple websites are autoplaying on my computer.

Two options
1)My sat internet is pinging so slow and it isn’t sending the block in time
2) Brave coding is getting old and being worked around

I think #2 because I’m naturally a hater :expressionless:

@Stupidhelpcenter,
Autoplay issues have presented themselves in Brave before – however, in general, autoplay blocking does work. Can you show me an example of the site autoplaying video even though the permission is set to Block?