YouTube Autoplay Blocked

These are my current settings and YouTube video autoplay still won’t work for me, nor do I get any prompt asking me to allow it. Is this a bug or am I being stupid?
Version 0.67.112 Chromium: 76.0.3809.62 (Official Build) beta (64-bit)

Thanks for reaching out. Can you try clicking the lock icon on the left side of the address bar and see if you can see Autoplay set to allow or block in the dropdown?

@Mattches it is set to Allow

Do you see the Autoplay was blocked on this page message appear in the address bar when visiting Youtube?

Oh my god I figured out what it is. I use the ImprovedTube extension to block out the related videos section for productivity reasons. When I switched over to Brave and imported my settings for ImprovedTube, YouTube’s autoplay (where it it plays another video automatically when you’re done with the one you’re on) was re-enabled, but the switch to turn it off was gone because ImprovedTube was hiding that entire part of the UI. I noticed an option for “video autoplay” in the extension and saw that it was on, and figured turning that off would do the job, without having to show and re-hide the related videos section again. This was the same time when I had just got brave and was looking through the settings—in particular messing with allowing autoplay—so I never put 2 and 2 together. The exension’s autoplay toggle was not for the youtube feature named “autoplay” but for the autoplay of videos.


Great detective work! :male_detective:
Glad you got this working – please don’t hesitate to reach out if you have any further questions or concerns.