Sync stops working randomly and cannot be restarted without new sync chain. (Bookmarks no longer syncing, send to device no longer working reliably either.)

The only way i found to fix it is to delete the chain completely and create a new one then connecting back my devices.

3 Likes

Yeah, that’s what I did when I had issues. Kind of wish I had been more patient so could get info to the devs. But it does seem like had been some issue not long ago where it stopped syncing for a lot of people.

2 Likes

The exact same error happened to me, probably starting around the same time as the original post. Ive been thinking about deleting the chain and starting again, but I have so many devices I need to redo, Ive been putting it off, and hoping for a better fix. And thats how I found this thread. I was hoping todays update had the fix, but nope.

1 Like

I’m having same issue since end of last week. Doesn’t sync between deviece.
I have one Andoid device and two PCs(one Windows PC and one Linux laptop).
Same errors in sync-internals as desribed above on all devices.

Sometimes it’s sync between desktop and some bookmarks have reached mobile, but from mobile, no new bookmarks come to desktops.

UPDATE: Created new sync chain and now seems to be working again. Have been using Brave with over year and it’s first time something like this happened.

1 Like

Can you let us know if the sync stops working again?

I guess yes.

However, I think you already have enough information to fix the problem!

FYI, for those interested here is the github link for this issue (opened Dec 26, 2023):

2 Likes

This has been happening to me for a while (8 months?). Brave SYNC has been unreliable and breaks every few months. The only solution I have found is to leave the sync chain and start a new one and re-join it on each device. Let the first device sync before adding a new device.

I have 9 or 10 dead corrupted sync chains by now. I have multiple computers and phones. I gave up trying to use them all and am happy now if I can get just my two main computers to sync. I have stopped using BRAVE on my phones because of this. I have also started using Vivaldi. It has been more reliable syncing for me.

I have tried a bunch of stuff, like only syncing bookmarks, I’ve read all the forums I can find. Only thing I can figure is that sync isn’t a priority now for BRAVE. Hoping they fix it eventually. I like the privacy features in BRAVE.

I kinda suspect the issue is BRAVE sync has set up some throttling on sync, restricting the number of items that it allows, and when users try and sync they hit some limit that disables more syncing. People could have only 100 bookmarks but maybe 50k user preferences, or history items, or whatever, extension settings, passwords, etc. If you hit the limit (when adding them all up) it times out and breaks everything for a day. But I am just guessing. It seems like when I do my initial sync it gets halfway done then stalls for a day until it finishes. I get to about 60k, then everything goes to “backed off” status and goes to sleep for a while.

I don’t have this issue with chrome, I have tested by syncing lots more bookmarks with chrome and it has no troubles. I don’t like chrome however because I have lost trust in Google to protect privacy. I like that BRAVE is chromium based with no google. There are other browsers that are also chromium based that I am trying out now. Syncing is essential and if BRAVE is unable to fix sync, for me at least, it will be difficult to continue using BRAVE as my default browser.

6 Likes

@Alexey
May I ask for an update on the sync issue, please?

4 Likes

Very frustrating. Just realized ios and macbook not syncing again. Syncing bookmarks is essential but time is probably even more important. Hate to go back to Chrome but at least it works without all these fixing requirements. Brave has been around too long for this to be continuing. Giving up hope.

4 Likes

Just realized I’m having a similar issue as everyone else in this chain. First noticed I had missing bookmarks between my android and windows desktop, then noticed I had missing bookmarks with my other desktop as well.

2 Likes

There are likely several hundreds/thousands of others who are having this issue but either (1) haven’t realized it or (2) don’t know to report it here. I didn’t realize I had the issue myself immediately since I don’t change my bookmarks that frequently. Like everyone else here, the only working solution is to delete the whole sync chain and re-do it on all of my devices–and I’m not sure how long this new chain will last either.

2 Likes

It has been exactly 30 days and the snyc chain broke again with the same

Commit Step Result Protocol error (TRANSIENT_ERROR)

as before. :expressionless:

@Mattches since this seems to be a widespread issue we really need some support here. Sync dying like that regularly is a major issue.

2 Likes

UPDATE: 2024-01-27
This method I described above has stopped working.
As of now Brave Sync is non-functional.

You should take all necessary precautions to preserve your data.

Also: Bookmark Import and Export are no longer reliable. When I use import and export it results in mismatch.

The only thing that works is manually copying the actual “bookmarks” file from within your profile folder from one machine to another.

If you want to be safe, MAKE A BACKUP COPY OF YOUR ACTUAL "BOOKMARKS" FILE NOW that is found in your profile folder.

1 Like

I had the bookmarks getting jumbled as well. I re-installed Brave on all devices except the main one. Using that one as the main seed, it duplicated well on a new sync chain.

UPDATE: 2024-02-03 (updated to new Brave version today)
Version 1.62.156
Chromium: 121.0.6167.139 (Official Build) (x86_64)

Sync has started working on two laptops and a mobile after the update.
Thank you dev team.

2 Likes

Was there a difference between the bookmarks on the difference devices? And how did that resolve, ie. are they mixed up or what?

With my four devices, I uninstalled then reinstalled Brave on three of them, using the main computer as the “seed” for all of them. Syncing has worked since then (a week or so).

Some are reporting on the Github page for this issue that the problem is resolved: https://github.com/brave/brave-browser/issues/35042

My devices appear to be in sync now. The bookmarks don’t seem mixed up.
I did not need to uninstall and reinstall.
During the failure period I kept only one connected to the sync chain.
After the version update I noticed that one stopped showing sync errors.
So then on the other devices I rejoined that sync chain.
Working now.

1 Like

Mine caught up (all of my devices appeared to be in sync) but the problem has returned – a new bookmark on my laptop is not appearing anywhere else.

I reported this at Bookmark sync isn't working, "OVER_QUOTA" – looks like the QUOTA was bumped from 50,000 to 75,000 according to the new error in the traffic log. This is not a fix, and it’s taken over a month to get this far.

If this thread is a separate issue from mine, I’m happy to take it over to my thread.

1 Like

Yes, issue is not fully resolved yet.

We increased the number of stored objects on the server to 75000, and decreased the expiration period for the History entry on the server from 90 days to 60. Tasks in progress are P3A metric for History objects count and make server to support History Delete Directives.

It looks 75k objects limit is not enough for 90 days for some users.

@HalJor, do you know how many items in history do you have on your most used device?
If this is a computer, you can check it with

  1. Open page brave://inspect/#extensions
  2. Click inspect under Brave extension
  3. Paste to the console
chrome.history.search({
  'text': '',
  'maxResults': 200000,
  startTime: 0
},
function(historyItems) {
   console.log('historyItems.length=',historyItems.length)
})

It may ask permission for code paste, then type by the instruction.

1 Like