Sync stops working randomly and cannot be restarted without new sync chain. (Bookmarks no longer syncing, send to device no longer working reliably either.)

Description of the issue: For the third time in about six weeks, sync stopped working. The bookmarks don’t sync and “send to your devices” does not work well either. (Sending from main desktop to mobile works slowly but mobile to desktop does not work at all.) I have been using Brave for years, syncing was never an issue before.

brave://sync-internals/ shows yellow boxes (they’re green when working) on the Type Info column:

yellow

It does say it’s “running” but also that it’s “backed off” in the yellow areas.

Under the Status from Last Completed Session column, I get a red “Commit Step Result Protocol error (TRANSIENT_ERROR).”

commit

The “request start” button flashes some boxes as bright yellow really quick (they then fade) but it doesn’t actually start anything.

The device list on desktop (shown below) and mobile (not shown) do not show anything strange.

On mobile, I went to sync and turned it off for that device (under Data Preferences). Restarted browser, turned “sync everything” back on. Did not work.

On mobile, I then left sync chain. Mobile sync page showed that leaving was successful. However, on the desktop sync page, that mobile device still showed. So I removed the mobile device from the desktop sync page. Restarted both. Desktop still shows that mobile device on restart. Why?

On mobile, I rejoined the desktop’s sync chain via QR code. Mobile show that it’s part of the old chain again but still no syncing going on. brave://sync-internals shows the same yellow boxes and Commit Step Result: Protocol error (TRANSIENT_ERROR).

In the previous last two times, deleting the entire sync chain was the only solution. This is annoying because: 1) I have to set it up for four devices and 2) I have to delete all bookmarks on all four devices and import a backup bookmarks list to the first synced device so the bookmarks don’t become mixed up etc.

How can I successfully restart syncing for the existing chain?

Brave Version(See the About Brave page in the main menu):

The most recent ones for Windows 10 and Android.

Version 1.61.104 Chromium: 120.0.6099.115 (Official Build) (64-bit)Win 10 desktop
Brave 1.61.104, Chromium 120.0.6099.115 (and the one before) on Android

2 Likes

@Mattches @steeven any ideas on this one?

3 Likes

To reiterate, this is weird and suggests some syncing is still alive. Same behavior today: desktop can send to mobile (often delayed by hours though) via right-click tab and “Send to your devices.” Same feature still does not work from mobile to desktop.

Now that it’s been over a day, the desktop send feature shows that the phone has been “active 1 day ago” despite receiving sent tabs/pages:

test

Oddly, when sending from mobile to desktop (which does not work), it shows that it is “Active today”

2 Likes

I’m experiencing the same error:

Status from Last Completed Session
Sync Source	GU_TRIGGER
GetKey Step Failed	false
Download Step Result	Success
Commit Step Result	Protocol error (TRANSIENT_ERROR)

Bookmarks are not syncing. It would appear they have not been syncing since 12/13/2023.

3 Likes

Exact same error across the board. All categories are yellow and Backed Off. Same protocol error. Mine is two desktop computers, so it’s a mutual problem computer to computer as well. I date a lot of my bookmarks by when I added them to help me sort them, and the last synced folder was on 5-16-2023. And it only sent half that folder before it just simply gave up and hasn’t made any bookmarks sync since then.

3 Likes

“Glad” to see others having the same issues. It’s not just me.

The “Send to your devices” situation:

  1. Desktop to mobile: it says the mobile was “active 3 days ago.”

  2. Mobile to desktop: it says the desktop was “active today.”

Again, neither works as intended. Desktop to mobile may works but can take many hours.

2 Likes

Same issue here, sync chain with 5 devices (3x macOS, 2x iOS). Worked flawlessly until today.

Now I get “Commit Step Result Protocol error (TRANSIENT_ERROR)”
and all yellow boxes in brave://sync-internals/ “Type info”: Backed off

Network

Throttled or Backoff true

The log says
“Commit Response Result: Success”, though.

Could we please get some support here? The sync chain randomly falling apart is a major issue.

PS: deleted my sync chain, made a new one, added all devices back and everything works again - for now.

2 Likes

Can you check back in a few weeks and let us know if it continues to work? My syncing stopped working again after about two weeks.

New update: It’s been over a week and “send to device” no longer shows on desktop. However, on the mobile browser “send to device” still shows (still does not work though).

1 Like

I actually started using the sync chain only about 2 weeks ago … so yeah, that seems about to be the time it stays alive … at best. :expressionless:

2 Likes

same problem here, why this?

2 Likes

Sorry for the late reply — just getting back from PTO today and still catching up.

That said I am not sure why these issues/errors are occurring but I have asked the Sync team to take a look. It doesn’t appear to be a known issue — closest thing I could find was an issue where sending to devices would cause the app to quit but even that appears to have been fixed already (https://github.com/brave/brave-browser/issues/34636).

Will reply back here as soon as I know more.

2 Likes

Same here. No sync between pc and android. “Protocol error (TRANSIENT_ERROR)” shows in sync internals.

4 Likes

I have the same issue. not syncing between several computers and one android phone. I get constant Backed off and TRANSIENT_ERROR

4 Likes

More or less the same problem on my side (Windows & iOS ver).

Until I reset the synchronization chain to zero by creating a new one, I had the same messages in the log. Sending tabs to other devices and synchronizing bookmarks between devices (I even permanently lost bookmarks in an in-between because of this disruption) no longer worked.

There’s only the problem of tabs from other devices still not appearing in the history page.

3 Likes

Hello,

Thanks for sharing, I am working on this issue now.

Here are some techinical details.
TRANSIENT or CONFLICT error is returned when the server doesn’t accept the client commit.
It usually happens when the server has object older than client tries to send. Client should download the newer object form server, merge and send updated back to server is required.
Also there is a recovery procedure which is fired on 7th failed commit and then client re-reads all the records of specified type PR#8201 and forcibly does all the required fixes and resolutions.
Somehow both of these didn’t help. I’ll try to figure out why.

4 Likes

Same issue here. All items in the “Type Info” column list the “Backed off” message, and I have the same “Commit Step Result: Protocol error (TRANSIENT_ERROR)” error status.

2 Likes

Thanks for the update. The only new thing on my end is that the “send tab to device” feature shows “active today” for both my main mobile and desktop. (Neither works… though I got a weeks old tab sent to my desktop a few days ago.)

active-today

In desktop’s sync page/device list, the mobile seems to have duplicated itself hence why it looks “active today.”

1 Like

I’m having the same issue as everyone here as well; all items in the “Type Info” column list the “Backed off” message constantly. Bookmarks aren’t syncing between several devices (windows PC, apple laptop, ipad, iphone). Some devices use the stable release and the beta; there doesn’t seem to be a difference with respect to browser version.

2 Likes

Update: If I go look at the latest commit response in the traffic log, I see a lot of “OVER_QUOTA: There are already 50000 non-deleted objects in store” errors. This doesn’t make much sense though; I only have a hundred or so bookmarks and my search history is not more than a few thousand pages over the past 90 days.

When I tried that on my mobile, I ended up with the sync page showing “Loading devices…” and nothing else. Sync does not work.