Sync on mac not working, similar to: https://community.brave.com/t/sync-nothing-happens-after-i-click-confirm-sync-code/49599

Description of the issue:

Steps to Reproduce (add as many as necessary):

  1. I have exactly the same issue as reported here: Sync: Nothing happens after I click 'Confirm Sync Code' but on a Mac with Android, iOS and another Mac on the Sync chain
  2. When Opening Sync on one of my Macs, I enter on the properly synchronized Mac to “View Sync Codes” and on the other Mac which is on syncing, I bring up “I have a Sync Code”.
  3. I input the Sync code into the new Mac and nothing happens when I click the “Confirm Sync Code.” The other system just bring up the spinner with “Looking for Device”
  4. Following the steps of inspecting Brave Sync, I see the following:
    "sync-debug" message="fetching devices" background.js:245 "sync-debug" message="fetched 1 devices" background.js:271 "resolved-sync-records" categoryName="PREFERENCES" records=[{"action":0,"deviceId":{"0":0},"objectId":{"...<redacted>...},"device":{"name":"<redacted>"},"objectData":"device","syncTimestamp":1554413087047}]

Actual Result (gifs and screenshots are welcome!):
No sync is occuring with only the new Mac.

Expected result:
Sync should occur

Reproduces how often:
Always

Brave Version(about:brave):
Version 0.67.124
Reproducible on current live release (yes/no):
yes
Additional Information:
Please feel free to request more information on this thread here.

Hi, @elencticdeictic, and welcome. I’m not having the same issue, but wanted to get a Brave rep/moderator/dev (@Mattches?) to change the tags because your post is tagged as Legacy (Muon) but your Brave version is actually the current Chromium-based Brave.

I was able to change into the “feedback” category but I really think there should be a bug category for this.