Sync: Nothing happens after I click ‘Confirm Sync Code’

Description of the issue:
Nothing happens when I click “Confirm Sync Code” on a fresh installation of Brave on macOS. I’m getting the sync code from Brave on Android.

Several people have registered the same issue, but all these have been closed without any solution, as far as I can tell.

If it’s relevant, I have set up sync in this order:

  1. Installed Brave on Windows
  2. Installed Brave on Android
  3. Set up sync from Windows to Android
  4. This sync is working as expected
  5. Trying to set up syncing from Android to macOS, without luck

Steps to Reproduce:

  1. Copy sync code from Brave on Android, for example “lazy fox”
  2. Install Brave on macOS
  3. Open Brave’s top-right menu, select “Sync”
  4. Select “I have sync code”
  5. Paste sync code “lazy fox” in text box
  6. Click “Confirm Sync Code”

Actual Result:
Nothing happens when I click the button “Confirm Sync Code”. It doesn’t seem to register the click at all.

I opened the console for chrome://sync/, but I don’t get any errors there either

Expected result:
I would expect Brave on macOS to sync bookmarks from Brave on Android.

Reproduces how often:
Every time I try to set up syncing on macOS.

Operating System and Brave Version:

Sync master: Brave 1.0.97 on Android 8.1.0

Sync recipient: Brave official build 0.65.121 64-bit on macOS 10.14.5

Additional Information:

1 Like

I found a workaround:

  1. Delete sync data
  2. Set up Brave on macOS with bookmarks and settings (exported bookmarks from Brave on Windows and imported on macOS)
  3. Set up sync with Brave macOS as master
  4. Syncing to Brave on Windows and Brave on Android worked
1 Like

@bjarteao Thanks for reporting. Issue is already logged, please track the issue here.

Thanks!

1 Like

@gsarvadnya that isn’t the same issue. Two different things.

I read the whole thread that @gsarvadnya has referenced. It is the same issue. It is still happening. Add me to the list.

I’m running on Windows 10 - Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit)

1 Like

It is definitely a different issue. I was able to sync between macOS and iPhone, but Brave on my Linux machine does nothing when I click “confirm sync code”. The code is 100% correct, I have copy-pasted it between browsers. Brave on macOS keep waiting for another device and Brave on Linux does nothing at all when I click the “Confirm Sync Code” button.

This topic was automatically closed after 30 days. New replies are no longer allowed.