Sync not working

Description of the issue:
Sync feature doesn’t sync.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Install stable version on PC.
  2. Import passwords or bookmarks.
  3. While on PC to to sync & scan QR code on mobile device (with stable version as well)
  4. Check if something synced & realize nothing happened

Actual Result (gifs and screenshots are welcome!):
Nothing, as sync was never successful.

Expected result:
Sync of what data was imported on PC.

Reproduces how often:
Each time I try to repeat the sync set-up.

Operating System and Brave Version(See the About Brave page in the main menu):
OS: Windows 10 Education 20H2 (19042.964)
Brave PC: Version 1.24.82 Chromium: 90.0.4430.93 (Official Build) (64-bit)
Brave Android: Version 1.23.76

Additional Information:
I’ve tried to switch the setup steps from PC to Android & Android to PC but it didn’t help.
I’ve tried to search an answer here on the forum & on Google but it led to more confusion finding that there was a v1 sync and a v2 and that numerous sync issues were reported since 2020 (that I would expect to be fixed until now or completely removed until they are properly working).

Can I try something to fix the sync that doesn’t sync across devices or is it still not working and needs further development?

Thanks.

@alexandru.lgu,
On your Android device, can you please perform the following (taken from our Sync FAQ):

Sync v2 on Android respects the system-wide option “Automatically sync data”, so if you found that Brave Sync v2 does not work on your Android device, you should ensure that system option is in the position on. The location of that option depends on device manufacturer, but you may find it in:

  • System settings --> Accounts --> Automatically Sync Data
  • System settings --> Accounts and backup --> Accounts --> Auto Sync Data
  • System settings --> Cloud and accounts --> Accounts --> Auto Sync Data

In order to sync v2 work on Android it is required to turn that option on.

Hi,

The Auto Sync Data toggle was on, I’ve tried before turning it off and on again and force a re-sync by clicking the sync button myself but it didn’t help.

Anything else I can try?

@alexandru.lgu,
Can you share a screenshot of your brave://sync-internals page so we can take a peek under the hood? Ideally from both devices would be great.

Sure, I’ve uploaded them here because it was easier: https://drive.google.com/drive/folders/1gKL8xUnujZZG1nvgXwyLbcNQQYIqqS_x?usp=sharing

1 Like

@alexandru.lgu,
Apologies for the long wait time here. Appreciate the images – I’ve contacted our Sync team to take a closer look and see what might be going on. Hope to have more information soon

@alexandru.lgu,
Just to confirm, did you enable all data types you want to Sync on both the desktop device and Android device?

Yeah, something weird is going on: I can’t get all mine to refresh a sync either (Linux & Android). In my case, I had to factory reset Brave on my main desktop (OpenSUSE), now I can’t get the desktop to sync from my other devices–which should have all the data (passwords, ID, bookmarks etc.). This has been going on for, perhaps, a week or two.

I did some more digging, and figured out what was going on in my case. The brave installation on my main desktop had apparently started a new chain even though I gave it the old chain. It would not forget the incorrect chain, even though I told it to leave that chain, and kicked it out of that chain. It simply would not leave the incorrect chain. I wound up deleting all the folders and files related to brave, to clear out the faulty chain references. Seems to be good now.

1 Like

@LanceHaverkamp,
Thank you for letting us know about this and apologies for the hassle. I’m glad you were able to get Sync working though.

Hi, sorry for the late reply, I did enable them on both my phone & desktop but since then I’ve got a fix, but it’s not very great.

Since I was having this issue & I got tired of MIUI 12.1 I’ve just flashed the updated 12.5 Chinese variant of MIUI 12.5 and this fixed my issue with sync. But I still don’t know what the initial problem was.

same here.
sync doesn’t work.

The QR code is displayed on the PC and is read by the Android side.
However, the Android side only recognizes one chain, and there is no change in the sync setting screen on the PC side.
How can I solve this problem?

Same problem, Sync data set to “sync everything” on Laptop 1 and Android Mobile, sync works. On my new computer neither “sync everything” nor manually selecting them all will stick, so sync does not work. I didn’t see fix, unless deleting everything and starting again id the fix? I hope not!