Suddenly Unable to Load Any Website with Brave on macOS Monterrey Latest

Description of the issue:

Yesterday, as usual, Brave was working fine with multiple profiles, windows, and tabs running. As of this morning, Brave will not load any Web sites no matter what I try.

How can this issue be reproduced?

  1. Enter a Web address, e.g., apple.com, techmeme.com.
  2. Wait for site to load.
  3. Loading fails with error “This site can’t be reached techmeme.com’s DNS address could not be found. Diagnosing the problem. DNS_PROBE_POSSIBLE”

Expected result:

Entering and Web address and pressing return causes that Website to load.

Brave Version( check About Brave):

Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (x86_64)

Additional Information:

  • Other browsers including Chrome, Firefox, and Safari are working normally.
  • Windows version of Brave works fine on the same Macbook Air via Parallels/Windows 10.
  • Disabled VPN, still fails.
  • Tried a Brave profile with no extensions enabled, still fails.
  • Downloaded and installed fresh copy of Brave, still fails.

Hey, try the solutions on this page →

Let us know if it worked. Cheers!

Thanks, but no luck. The suggestions were:

  • Restart your internet connection.

Connection is fine - Chrome, Firefox, and Safari all browse normally.

  • Disable your firewall and antivirus.

This is macOs with no additional firewall or antivirus software. Also, no changes were made since last night.

  • Clear your browser cache.

Tried, still fails.

  • Flush your DNS cache.

Done, still fails. Also, tried an IP address and it resolved to the expected domain, then failed.

  • Change your DNS servers

Again, my Chrome, Firefox, and Safari browsers share the same DNS setup and are browsing normally.

Umm okay. Probably someone who knows more about how brave works can help you better. Do check if you’re using the latest version of Brave.

Thanks, appreciate you taking the time to help. And…just found a fix, but it’s not ideal:

  1. Quit Brave.
  2. Renamed the ~/Library/Application Support/BraveSoftware settings folder.
  3. Restarted Brave.
  4. It works!

It means losing all my settings, extensions, etc., but better than not working, for sure.

Oh that’s great that it works now. Not the ideal solution but yes something is better than nothing :joy: