Brave / Mac : "This site can't be reached"

I am on a Macbook. My computer works very well. All the other browsers work fine. My internet connection is good. I am on the web all day.


Brave has never worked. It installs fine. But I have NEVER been connected to ANY webpage.

“This site can’t be reached” is the only thing that Brave ever told me on my Mac.
I’ve already spent some time :
• I have no extensions on Brave.
• Yes , my connection to internet is working very well.
• Yes I have tried to create a new profile.
• No i don’t have a VPN

C’mon. This is getting ridiculous. All the other browsers work fine. But It is Brave that I want to use. DO SOMETHING for F sake.

MacBook Pro (Retina, 15 pouces, mi-2015)
System Monterey 12.6.3

Which site? Does the site work in Brave beta/Nightly?

ALL sites
ANY site
Brave does not connect to ANYTHING.
Nor does Brave beta / nightly

Maybe an SSL issue, or a DNS issue? Try updating to the more recent version of macOS Monterey 12.7.1

I have 2 Macs (M1 & M2), both work fine with Brave. So its not a issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.