Stopped getting ads and BAT rewards for last 4 months

Out of no where I stopped getting ads and rewards. My account is linked to uphold and it’s verified. I checked also CDD questions on my uphold wallet and that’s not the problem…

2 Likes

@Ullitaja it’s hard to let you know what might be going on without knowing more. Obviously if you’re not seeing ads, you won’t get rewards. If you want to check out a longer thing I recently shared, you can check out PSA: Friendly Reminder For People Having Issues with Rewards/Ads

If you want just the official guide on things that might be interfering with ads, you may just want to jump to https://support.brave.com/hc/en-us/articles/360055013431-Why-don-t-I-see-any-Brave-Ads-after-enabling-them-

1 Like

Well it has to VPN( I mostly use US ip) I guess then but the funny thing is that it wasn’t a problem last year from May to September!

Yeah, that is weird. I do know as updates are done and they improve on features and security, that could end up leading to the changes. Though I’m not saying language as much as time zone and all. For example, there was a user who posted about how he and his friend lived in Costa Rica but his friend wasn’t seeing ads. The trick though is Costa Rica had multiple time zones and that’s what was causing the issue. If you want to check out that Github and the various comments, check out https://github.com/brave/brave-browser/issues/4221

As to the person I’m talking about, here was his:

I see the ads, but my friend which use Windows 10 can not see them, we both live in Costa Rica but in different zones (He lives in Heredia and I live in San José)

basically, this seems to be an issue of locales, I will match his locales and try again

matching the locale on WIndows 10 ( Español (Costa Rica) instead of Español (Latinoamerica) ) fixed the issue for him.

There was even another person:

My Windows 10 version is 1909 (build 18363.752).

My country is set to Czech Republic.

Information from https://www.iplocation.net/:

ipaddress

When I set the regional format to English (United States) , Brave says that rewards are not available in my region.

When I change the regional format to Czech (Czechia), Brave rewards are enabled for me.

So the only thing I can suggest is to try to make sure your computer’s time zone/locale matches with whatever your IP is set to be. If your computer is saying you’re in England but your IP address says you’re in the United States (just using as an example), then Brave would be flagging it as an issue and be unable to show ads as they are uncertain of your location…which is a key aspect of knowing what ads to show you.

Try changing that up and let us know if you see a difference.

1 Like

I stopped getting ads a few months ago also. I have checked and rechecked settings and everything looks fine. I get NO ads thus no payout which I really miss.

Appreciate all the help so far but no luck. Changing location didn’t do anything…

Also from the beginning I was never able to get any BAT from my android. Every time I tried to claim it said the error> Oops something went wrong, try again…

I see, that changes things a bit. There haven’t been many resources that I’ve seen on that issue, so definitely will hope @Mattches can point in the right direction.

In the meanwhile, I will at least share what like I have found. They are all basically just verifying everything is up to date and all.

  1. Is your device rooted? If it is or if other security issues, you’ll be unable to claim. A community ninja on the site suggested to verify no issues by using Google SafetyNet and linked to https://play.google.com/store/apps/details?id=com.flinkapps.safteynet&hl=en_US&gl=US
  1. Make sure you’re updated to the latest version of the Brave Browser. On Android, this will require you to go to Google Play and update the Brave App

  2. Clear the cache on your browser

  3. There’s another I saw randomly on the internet that mentioned turning Rewards off and then back on.

Not sure if any of that will help, but figured I’d toss out what I could. If you try those and no issues discovered, I’d suggest you tag Mattches or Saltybanana and/or DM them as well and let them know what you’ve tried, as well as your device, operating system, and browser version is.

2 Likes

@Ullitaja,
When you say

Do you mean you found and completed them or that you didn’t see them at all?

So… Win7 is no more supported to receive POPUP ADS ?

@Infoxvids that is correct. One option you can try is our new custom ad notifications (eventually all ads will appear this way) but note that this particular feature is still being tested (which is why we don’t use it everywhere). This new method does not leverage the OS notification system so it will likely work in your case.

To do this:

  1. Open Brave
  2. Go to brave://flags
  3. Search for a flag called Enable Brave Ads push notifications and set it to Enabled
  4. Restart the browser

Browse normally and check and see if ads start appearing again.

4 Likes

The Option Work flawless, thank you.
But I don’t understand this choice to exclude win7 users,
the browser is not part of OS who cares if OS is outadated?
OS have security problems? the user will take care of it updating or taking his risks

cheers
Claudio

@Infoxvids Mainly because operating systems end up changing a lot of details. In order for programs to continue existing for old operating systems that means that developers have to create multiple versions of their program and make that available or at least add in lots of extra lines that code.

As operating systems lose the amount of users, it becomes a matter of profit versus loss on spending time to keep things running on the older systems. On top of that there are a lot of features that cannot be replicated on older systems. Sure, there’s ways around it sometimes, but it’s usually not worth it

I can’t sign in to my google account through Brave. Here’s the error: 400. That’s an error.

The server cannot process the request because it is malformed. It should not be retried. That’s all we know.

Ive tried points 2, 3 and 4 multiple times without any luck as well!

And I can’t find anywhere those CDD questions on my uphold account…

Ok I managed to get Safety net Checker on my phone and here are the results:
WeChat Image_20220127024556|343x500
I have no idea what those mean though :sweat_smile:

Thanks for your Brave flags suggestion!
It worked for me. First ad in 2 1/2 months!

@Ullitaja Bah, didn’t see you had responded 4 days ago. It’s part of why I always @ people, so it will create a notification.

Anyway, I know I just linked and provided basics. When it comes to CTS and all, article I was seeing about it is at https://www.hexnode.com/blogs/safetynet-android-security/

But best way will be to tag @Mattches here since you also answered the question he asked you 5 days ago.

I’ll also tag @megaspaz to see if they are available, as they were the ones to speak of SafetyNet elsewhere, so perhaps they will be able to speak on what to do.

@Ullitaja,
If your device does not pass the SafteyNet check that it is ineligible to receive Rewards.

@Mattches Ok that’s the android part…which never worked from the beginning. But what about the windows browser which stopped sending me ads and rewards. I’m also gonna add my chat with the uphold support if that helps at all…

@Ullitaja,l
Apologies if you’ve done this already but can you please send me a DM with your wallet payment ID, found on your brave://rewards-internals page?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.