Still no joy with 1Password and Brave

On Mac OS 10.11.6 I can’t get 1Password to work at all. I’m not sure if it’s a Brave issue or a 1Password/Agilebits issue, but 1Password works in every other browser I’ve tried.
When right-clicking to select 1Password and enter a login, I get a "browser could not be verified’ message that prevents me from activating 1Password’s login-entry feature. I have to manually open 1Password’s desktop software, search for the login I want, and copy/paste each item (user name, password) into Brave each time I want to log in somewhere.
I’ve deleted the 1Password desktop app completely, reinstalled it, and removed and reinstalled the browser extentions. Whenever I try to install the Chrome extension for 1Password into Brave, I get a message that the extension is searching for the app. Even though I always have the app open and running, Brave actually CLOSES the app, then complains that the extension couldn’t find the app it just closed, and therefore it denies there’s a compatible 1password installation on my Macbook to allow its extension to function.

Hi, @Chippewa. I’ve gotten 1Password to work with Brave on MacOS 10.14. I’m about to try it, again, to be sure it still works on Mojave (in Brave Release 0.66.99 and Nightly 0.69.44).

Could you confirm your Brave version by typing brave://version in the address bar and hitting return?

1 Like

@Chippewa which 1Password version that you use?

You need 1Passwors 7 in order to use it with Brave.


1 Like

@eljuno makes a good point and has in related threads provided links explaining why 1PW6 won’t work.

@Chippewa, I tried the already-installed extension in one of my Release profiles and it reconnected to 1PW7 fine, so I switched to a profile that doesn’t have the extension to try the installation process. HOWEVER, 1Password now offers what appears to be a standalone extension that might obviate the whole connection thing.

If you still want to use the application-connecting version, then it sounds like you’ve already tried the steps from here. However, another post by @sfobrian right under that solution suggests that you can:

  1. Open Activity Monitor
  2. Look for and force quit any processes belonging to 1Password
  3. Reinstall per @ElectricSeal’s steps linked above and connect

Let us know which way you go and how it turns out.


Well, shoot. I have 1password6. That stops me right there; I already paid for 1password 6 and won’t agree to paying all over again for a new version of the app I already bought.
I’m gradually migrating my password data to lastpass instead.

1 Like

Did you try the new(ish) apparently-standalone extension? It doesn’t say it requires any particular version of the application to work.

I just activated the 1Password X extension and it doesn’t appear to call on the application at all, acting like a real, standalone thing. And in fact, connecting with the application appears to be optional based on this from the 1Password site:

To integrate with 1Password for Mac

If you use the 1Password for Mac beta, the 1Password X beta can integrate with it. Click the 1Password X toolbar icon in the toolbar, then click the settings icon > Settings, and turn on “Integrate with 1Password for Mac”.

When you turn on integration, 1Password X will use 1Password for Mac to:

  • lock and unlock (supports Touch ID)
  • create and edit items
  • sync your accounts and preferences

You can also fill logins in your browser directly from 1Password for Mac.

So migrating to LastPass doesn’t appear to be necessary at all.

This topic was automatically closed after 30 days. New replies are no longer allowed.