Some sites have sudden problems in Brave

Hi Ken, thank you for trying out the backstep. I haven’t had time to try this myself, but I think you have established that it is something connected with the new version. Hopefully that, and the info I found that it seems to baulk incorrectly over content security policies and inline scripts, will give the Brave team enough info to pinpoint the problem. I hope this is resolved soon as I am finding more sites are unable to run properly without the two-step shuffle, e.g. Google Translate. Out of interest, now that you have gone back to the previous version, how do you stop Brave autupdating itself to the broken release again?

Hello Olande, I have not stopped the update process. I’ve only delayed it by not relaunching the app. There is a message on the on the About page reading “Relaunch Brave to finish updating”.

There is a thread on the topic of preventing updates with a possible interim solution at The option to turn ON / OFF Automatic Updates. Please - #4 by mikchester.

I may try it. Meanwhile. I haven’t exited the app or rebooted the PC.

Adding myself to the list, Brave started blocking scripts and breaking functionalities with
Refused to execute inline script because it violates the following Content Security Policy directive: "script-src *". Either the 'unsafe-inline' keyword, a hash ...
I understand this can be a security issue, but I’m using the browser to configure appliances in my network and I just can’t patch the GUI for all of them when non compliant. I think this should be configurable by the user, maybe per-site/domain, and have some grace period.
I will go back to Chrome while this is fixed, don’t want to go back to older versions and break auto-updates.

Hi Ken, thanks for the info on the automatic updates. In that case, I don’t think there is much point in me trying to revert to the previous version if it is going to update itself again tomorrow morning. You have saved me some added frustration there.

Hi Rimbalza, thank you for adding your voice to the list of people with this problem and for confirming you are seeing the same inline script issue as I spotted. I am not convinced this is a security issue since the browser will quite happily run the inline scripts when I’ve pasted the page url into the address bar, but fails with the error when that url is a link in a file on my disk. It is still the same page and the same script, regardless of where I found the link.

Your post reminded me that other things on my network have browser interfaces for config, so I checked my broadband router and discovered that is afflicted with the same problem. Like you, my interim solution is to use an alternative browser and to hope this is fixed sooner rather than later.

Just received Version 1.25.70 Chromium: 91.0.4472.77 (Official Build) (64-bit) this morning, same problem. Of course on the same pages Chrome, Edge and FFox are ok.
Time to migrate.

Hi Rimbalza, I checked my installation and yes, it has likewise updated to 1.25.70, and I can confirm it has made no difference to me either. I don’t know where we can find out info about what goes into each new version, or what the reason for the update was. Something I am now finding frustrating is that between us we have clearly identified a significant bug and pinpointed the time it was introduced into the code, but I have no way of telling if the Brave developers are aware of this, logged it, if they have been able to reproduce it, or consider it worth their time fixing. Like you, after struggling with this for a week I feel all I can really do is abandon Brave go back to Chrome or Firefox.

Hi Rimbalza and Olande: What I have found so far, for the updates since May 27, is that most troublesome websites arise from Brave trying to use the https:// prefix, not the http:// prefix. When I change the https to http, I usually get to the website. I am relying on Chrome when Brave doesn’t allow me to get the website.

I am having the same problem. If you

  1. create a new HTML file with a link to https://duckduckgo.com/
  2. and view that offline HTML file from your local computer in Brave (Windows and Linux)
  3. then click the link

you should see the result.

You can go up in the address bar and hit enter and it will load, but doing this every time is a huge pain.

Just put this in a file called test.html

<html><body><a href="https://duckduckgo.com/">Link</a></body></html>

Again, view this from your local computer and NOT a web server. In other words, double click the html file.

Change the link to startpage.com and same thing. Many sites are broken like this. But if you put the file on a web server, it works properly. Only if it’s local does it cause this issue.

Hi Browsin, I posted some very similar HTML to you back when I started this thread, but received a message saying that as a new user, my post was blocked until approved by a forum admin. That was over a week ago and still not appeared, so I am glad you posted demonstration code as well. I suppose some might say this bug is only affecting a small group of users in a particular situation, but I think it points to some sort of problem handling content security policies and may be affecting other areas which are not so obvious.

Following your observation that DuckDuckGo was broken, I checked google.co.uk and found that when launched from a local file, that too doesn’t work properly. The feature which fills in suggestions as you type doesn’t operate, and when I checked the console, there were the same errors about content blocked by client as seen on other sites. Increasingly I am using other browsers because of broken sites in Brave.

I have logged an issue, and we’re investigating this.

Apologies for the regression

Hello Olande, you are very welcome!

This morning my browser has updated to

Version 1.25.72 Chromium: 91.0.4472.101 (Official Build) (64-bit)

and that has solved the problems I was experiencing with Youtube, Google, the BBC, Worldometer, etc. I am not sure if that is due to a Brave update or the Chromium update, but either way, it is good to have my preferred browser working again, so whoever was responsible, thank you. Strangely, the Radio Times site is still not working with shields on, but does work with shields off, even though immediately prior to this issue, it worked fine every day with shields, but that one always looked a bit different to the others and I’ve now reported that one via the browser shields function.

Like Olande, I have noticed that Brave is now working correctly again. Thanks!