Site issues with Brave

I don’t know what happened to the thread I started last week detailing 2 issues, but I can’t find it anywhere :frowning:

I’ll have to go with the one issue that’s happened since then.

Once again on Vitacost I was unable to see things properly. When I went to Chrome all was fine.

I couldn’t see the Review stars at the top of the product page & when I clicked on Reviews (a link) at the bottom of th epage (it’s normally never at the bottom), it gave me blank white space.

I’m starting to encounter more issues with Brave.

This? - Can't write review

I’ll take another look

Just wanting to know this issues regarding the reviews. If I click on Reviews I can see the reviews. Is this not what you’re seeing?


Yes, those reviews & now they are showing up, but they weren’t the other day.

It wasn’t to write a review although I had that problem a few months ago, it was seeing the reviews.

So I wish my other thread could be found. Can you find it?


See my first post on this thread ^ Links to your original thread.

Could’ve been a server-side issue rather than a Brave issue? but if it happens again (and is consistently reproducible) let me know

No it wasn’t that one. That was an older one.

Ok, more issues & I am really getting irked.

I can’t work like this constantly having to remember that it’s not the site, it’s Brave b/c it works on Chrome…

1. In AdRotate (this is a WP plugin), I clicked on "Select banner" & it does nothing. It works in Chrome.
2. - wouldn't play, played on Chrome
3. Couldn't type anything in the search field, works in Chrome -
  1. Sure, Being ad-related, I could issues with this. Possibly just disable site trackers on that site?
  2. (Just allow all cookies)
  3. Need more info here, but did an initial search for test on and it gave me some results.
  1. What do you mean being ad related? It’s a plugin that allows me to add banners to my site. Why would Brave block that?

  2. I don’t know what you mean by “allow all cookies.” I never turned off cookies.

And I didn’t understand where this drop-down menu is mentioned in that Github thread is.

  1. I can’t type in the field. I think one of my extensions may be causing the problem. I thought it was The Google Translate one, but when I tried it on another Brave person with that extension, it does work & it works on other persons that don’t have that extension.

I just don’t have time or energy to disable (NVM) I did it.

It’s this one that’s causing problems - ScriptSafe.

My website coder had me install it b/c Vitacost was spamming me with this Chase bank BS & every time I go to purchase I have to wait for it to load & then X out of it wasting my time.

So can you fix that?


What do you mean being ad related? It’s a plugin that allows me to add banners to my site. Why would Brave block that?

Yes, we block ads in Brave, so if its a banner. Yes I can see it having issues with us. Disable Shields or Site-trackers as a first step on that site.

I don’t know what you mean by “allow all cookies.” I never turned off cookies.

Allow all cookies in Shields when using Google Drive, this will allow video playback. Its just a bug.


I can imagine this extension can cause a few issues, test sites without it enabled if you’re having issues. Also, the Scriptsafe extension hasn’t been updated since 2017.

1 Like

Oh, so how do you turn off the shield or site tracker for each individual site? I went here & don’t see anything like searching for an individual cookie -!FkskzC4a!R8f9chVLISdnEhU5JzWU_s3ukmT42Z8yRK2XG2xxeVQ

Same question as above.

Oh, I had no idea it was that old. Sorry

On another note…

I found one of the previous issues that was in that thread that disappeared.

It’s this one…

1. Once again Vitacost issues where I can't see the reviews which should be at the top (the stars) -

and this is something I just figured out today…

2. I am pretty sure now that Brave is causing all the problems of this extension not tracking the points I get when I purchase things. AAdvantage eShopping - even though the popup shows up & I tell it to activate, some points are being tracked, others aren't.

I just used Chrome to make a purchase & I got an e-mail confirming my points whereas with Brave I never get that e-mail. I checked.


In the url bar, click on the shields icon. and you can tune this for per site.

1 Like

Thanks & my friend got me another script blocker which we tweaked for Vitacost & now it’s blocking the STUPID Chase bank incessant popup.

I’ll have to test the air miles thing with the brave shield when I purchase again.

In the meantime Chrome is coming out with this same thing tomorrow. Will it be exactly like Brave?

Another issue that has happened several times.

I use Manage WP & it should show the thumbnails here, but it never does unless I clear the cache & refresh.!A8VmCa6D!Hz4QBGUyobvef6cX1N-_uYY_nxiZ6WNEB_qW67y2Dm4

On Chrome this doesn’t happen.

That’s the drop down menu that shows all my sites.

Which Chase bank popups from which site?

The Manage WP might be harder to debug, does turning off sheilds/clearing cookies cache help?

1 Like

Vitacost when you go to checkout, it loads a stupid Chase popup & so we started using the UMatrix extension to stop it, but that has nothing to do with why it’s not tracking my orders via the AAdvantage e-shopping extension & that’s a way more serious issue b/c I just wasted tons of time having to argue with them that my miles aren’t being added to my account. e-mail over & over again to get a manager, then after weeks went by, I had to pay someone to figure out which miles weren’t added to my account & now I’m waiting on them.

So a really big costly headache.

Brave is really beginning to feel like it’s not worth it. :frowning:

Another huge issue…

02-09-20 - tried to log in here & I got a blank white page, but Chrome logged me in no problem & I did turn of the shield to test - also earlier the sites were just spinning & spinning. Again, wasn’t doing it on Chrome.

Turns out when my website coder came onto my computer via Skype screenshare, the reason WHY my CPU & memory was at 100% was b/c of those spinning site tabs. :frowning:

I had forgot about them & didn’t realize how bad it is to leave them there spinning like that.

Once I Xed out of all the tabs, my computer went down to the normal CPU/Memory usage.

Again, it’s NOT doing this on Chrome.

Might have other issues?, displays fine with shields enabled

Ok, could it be b/c I’m logged in & you aren’t?

What about the AA miles issues?

Needs more details about the AA miles issues, Like Url and step by step to reproduce it

This is the name of it AAdvantage eShopping℠ button

It automatically popsup when you go to a site that uses the program. You either click yes, track miles (or something now), or activate later.

I click on activate when I’m ready to buy, it then logs me into the site automatically. When I’m finished purchasing, another popup should appear saying the order was tracked & I should get an e-mail saying the order was tracked.

Often I get the popup, but not the e-mail. I had forgotten about the e-mail until the other day. I thought it was tracking my orders this entire time, but I guess it’s not even though it says it is.