Brave Desktop not rendering

Brave suddenly stopped rendering properly. Not only websites but even its own settings page.

A screenshot of the setting page:


You can also see that the search bar as well as other icons fail to render.

This affects all websites etc. All other browsers etc work fine (not a hardware issue).

I also installed the latest version form the official website (without uninstalling the current version) to force it to update (if an update was available) but no luck.

Any help you be greatly appreciated!

4 Likes

I am having the same problem. Started yesterday. I think it happened about the time I installed the latest update. Not a single page works. This is a screenshot of my GMAIL page. I actually had to use Firefox to get to the Brave site to submit this.

3 Likes

I’ve also noticed that ever since my Brave Desktop browser meltdown, that my bluetooth is intermittent when the browser is open. My mouse and keyboard (both bluetooth) will go non-functional every few seconds, and will stay that way from 5-10 seconds before becoming active again. As soon as I close Brave Browser, functioning returns to normal. This happens whether or not I am using the mouse or keyboard with Brave Browser. It occurs as long as Brave Browser is open, even if it is minimized.

2 Likes

I have also experienced this exact behaviour with the intermittent Bluetooth one day before it stopped rendering

1 Like

Still could be a hardware issue, in terms of graphics card. Especially depending on settings within.

I’m going to ask you to attempt three different things:

Test 1:

Can you try the instructions below, which I’m copying over from a post by Mattches.

  1. Find the shortcut for Brave (generally on Desktop), right-click and select Properties from the context menu.
  2. Click into the “Target” field, and type --disable-gpu at the end of the path. Note that you must type this outside of the quotes with a space between the flag and quotes. It should look something like this:

  1. Click Apply then OK then open the modified shortcut you just created.

Test 2

If the above has no impact, then instead of the gpu part, put --profile-directory="Test Profile" at the end of the target. So it will look something like "C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe" --profile-directory="Test Profile". This should launch your browser in a new profile, which would run with default settings and no extensions.


Test 3

If the above doesn’t work, I’d also like you to try getting Brave Beta or Brave Nightly and see if you have issues on them?

Test 1 worked for me! Back to normal now. Thanks for your help @Saoiray

Just so you know, that just means it’s a compatibility issue with your graphics card or settings. You may want to try updating your drivers and look into your settings. Are you using NVIDIA? If so, go to NVIDIA control panel and check how things are for Brave. For example:

Then would want to try again without the disable gpu command. The --disable-gpu is just opening your browser with Hardware Acceleration off. This means it’s not using your GPU to process anything and is completely using your CPU. It works, but might not be the best performance.

Disabling GPU acceleration worked. Also updated NVIDIA drivers which seems to have fixed the issue properly! Thanks!

1 Like

I do have Nvidia - Quatro T1000. I downloaded latest driver and made sure my nvidia screen matches the one you show but if I take off the flag from the target, Brave browser returns to gibberish. Looks I will have to leave the flag on. I appreciate the explanation and will keep looking for a solution that will allow me to leave Hardware Acceleration on…

So essentially comes down to settings or extensions, I suppose. Have you changed anything in brave://flags? If so, maybe try readjusting.

And if you haven’t, it might be a good place to mess around with as well. For example, I noticed if I enabled Vulkan, my graphics in Brave went to crap. So I have it disabled.

Then also is a possibility that changing one of the ANGLE graphics choices might matter.

Unfortunately, there’s a lot of moving pieces. Only thing we know for certain is it’s something within your graphics card or graphics settings. And if it works fine elsewhere, then it’s something specifically going on with their settings regarding Brave.

Heck, to be honest, even just renaming Brave to chrome.exe has solved for some people in the past, because the graphics companies prioritize Chrome, Edge, and Firefox over all else.

Good advice. I will try some of those ideas. Thanks for the extra time on my issue.

Update, issue came back.

Can confirm Nvidia control panel looks identical to the one mentioned here.
No extensions installed (other than google translate).
No flags changed. (Vulkan is disabled)

@Mattches and @steeven I want to tag y’all on this. Honestly, I’ve been seeing a lot of people having graphical issues on Brave for the past couple months. Sometimes we’re able to fix it through adjustments to settings, but it’s random. Weirdly enough, it’s only Brave that seems to be impacted. All other web browsers and programs display appropriately.

Challenge is I still haven’t found any root issue.

@dem2k and @samsolo next thing I’m going to do is see about gathering some more info. Can you both go to brave://gpu/ and Download Report to File? Make sure it’s a Text (Txt) file. You should be able to upload (look for the image button) here. If not, can look at other ways to share. But hopefully will be able to upload with no issues. I’m assuming that will contain a bit of info that might be helpful to Support and the Devs.

Oh, as I was looking, I see Mattches created an issue for this on Github, over at https://github.com/brave/brave-browser/issues/34806

EDIT

Actually, after talking he made a different Github.

1 Like

Can’t find the button, but here is the attachment. Thanks for looking into this!

about-gpu-2024-01-24T03-58-54-445Z.txt (68.5 KB)

1 Like

This started happening to me as well, on Monday.
I have not found a single site that loads correctly.

I’m using a Dell XPS 15 9500 Laptop on Windows 10 Pro x64 with Nvidia GeForce GTX1650Ti.

Deleting the GPU cache folder did not help.

Disableing GPU acceleration fixed the problem, but now the browser seems pretty slow.

It wont’ allow me to post any uploads…

Here is another possibly related thread: https://github.com/brave/brave-browser/issues/30185

Here is my report as well.
about-gpu-2024-01-24T18-59-20-633Z.txt (1.2 MB)

1 Like

Thanks, I’ll tag in @Mattches so he can try to grab those reports.

1 Like

Thank you all for reporting — have added everyone’s information to issue linked above.

1 Like

Today’s update (v1.62.153) seems to have fixed the issue for me. I will update this thread if the issue still persists. Thanks everyone for their help!

3 Likes