Some sites do not come up in Brave

It’s really getting frustrating using Brave (on my Mac). I would estimate that about 5% of web pages do not come up in Brave. I have to bring the URL over to Safari to bring up the page. And yes, I’ve tested every one of these pages with all shields down–for both for the site and global. I’ve also turned off all extensions.

What am I missing? Surely others have this issue.

MacOS 10.14.5
Brave Version 0.65.121 Chromium: 75.0.3770.100 (Official Build) (64-bit)

This is why it’s important to stick to do your best to adhere to the template and guidelines. I don’t really have a way to fix or test against “some sites” nor can I infer what sites from your post.

Can you please provide some example sites you’re having issues with currently?

They are random and havent been recording the ULS. But here’s one I just got this morning:


It’s a LONG crazy link, but it it does work when I go to Safari or Chrome.

It said that I had to login to view the link you sent. However, I was able to visit and navigate around the the base URL ( without issue:

Again – more info would really be appreciated. Does the site load infinitely or does it eventually error out? If so, what error messages (if any) are shown? Does it work with Shields down? Are there similarities between this site and any otherS?

Not sure how helpful this is, but I just tried in the same version of Brave on macOS 10.14.5 and it came up quick. Hit a story with same result.

@slobizman, are you running any other extensions in Brave? Like DuckDuckGo’s enhanced privacy extension or uMatrix or something?

I don’t even get to the login for the page, from the Link I gave you.

It just stays a blank page. It does not eventually time out. It just sits there like that.

As I had mentioned, it does not work with shields down or with global settings turned off. comes up for me, but not the specific link (except in other browsers).

I have extensions, but I’ve tested it with them all turned off.

Interesting: I went to my iMac and tried the same link. It worked in Brave.

So I went back to my macbook pro, where the problem was happening, and tried again. It did not work still. I then changed Ad Control to “Allow ads” to match my iMac (which is Allow Ads, Block 3rd party cookies, and Block all fingerprinting). It worked!

Then, I set it back to “Block Ads.” Surprisingly, it worked this time.

So, I don’t know what’s going on. But I will update when another site comes up that has an issue.

Solid investigating. It may be that a one-time check for ad-blocking behavior or one time cookie-set needs to be made before the site can be viewed but that doesn’t explain why me or @hnktong were able to view the site as intended first try.

Will dig a bit further into this but glad that you got this working.