Facebook will only load an error page, even with Shields Down

bug

#1

Description of the issue: Facebook will not load any pages in Brave browser. I’ve tried all troubleshooting methods I can find and it continues to have the same behavior, even with Shields Down entirely. It loads a page (screenshot attached) which says “Error. Sorry, something went wrong. We’re working on getting this fixed as soon as we can”. This is not an issue with my connection or facebook account - loading the website is working flawlessly on every other browser and mobile.

Steps to Reproduce (add as many as necessary):

  1. Open www.facebook.com
  2. page will not load under any circumstances

Actual Result (gifs and screenshots are welcome!): https://imgur.com/a/Eu3mln9

Expected result: Page opens a functional part of the website

Reproduces how often: Every time

Brave Version(about:brave): Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

Reproducible on current live release (yes/no): Yes

Additional Information: N/A


#2

Using Version 0.60.23 Chromium: 72.0.3626.96 (Official Build) beta (64-bit) on Mid-2015 MacBook Air running MacOS X 10.14, facebook works fine with mostly-default settings. Maybe try updating Brave (recognizing you probably did that, already)?


#3

I’ll post my computer specs as well if that’s helpful:

Early 2015 Macbook Pro, OSX Mojave version 10.14.3.

My Brave Browser says that it’s up to date (and I just downloaded it a couple days ago, unless a new build was pushed I should be on the most recent public version) - would you recommend installing a beta build to see if this is still problematic?


#4

I’d forgotten I’d installed the Beta, so I went to the download page, downloaded the main release, and tried facebook again with the same build you have. We’re running very similar base systems, it seems, and now using Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit) I still get successful login and apparent full functionality. At this point I’ll bow out and leave it to those with better KungFu.


#5

@adamrust,
Thanks for reaching out.
That’s pretty strange - I’m able to authenticate into FB without issue using (roughly) the same setup as you.
I know you mentioned that you’ve tried all troubleshooting steps so forgive me if I repeat any - but we have to make sure we cover all our bases.

The first thing that comes to mind is clearing your browser cache, as issues like this are often resolved this way. Can you try clearing your cache (and maybe cookies) or confirm if you’ve already tried.


#6

Hi, thanks for the reply! I’ve just double checked by clearing my cache and cookies and the issue persists. I’ve got no idea if this is helpful information, but the page that I get redirected to has a URL of “https://www.facebook.com/?__fns&hash=Ac1yu1Ymm2ZagL01


#7

It seems like this is a caching/authentication issue on Facebooks side rather than the browser side. Doing some research yielded many users reporting being directed to the same page you referenced.

Many users reported clearing browser cache/history/cookie data to solve the problem. Others mention authenticating using a different browser or device, then trying again (FB may have some sign-in shenanigans at play here), others simply waited. Here’s what I would try:

  • Ensure that all FB cookies are cleared from Brave, use a separate browser (or your phone) to login to FB (successfully). Log-out, return to Brave, on FB login page, open Shields panel and Allow 3rd party cookies (you can re-enable this after authenticating in) and try again.
  • If that doesn’t work, open a Private Window session (access this from the menu or using Cmd+shift+N for macOS or ctrl+shift+n for windows) and try to login there.

Let me know what you find out.


#8

Well I’ve got no explanation for “how”, but the issue seems to be resolved now! I logged in/out in a different browser, then came back to Brave to realize that, duh, when I go to any facebook page it redirects to the error, so I can’t actually visit the log in screen as you’d suggested.

I tried to search for a specific link to a facebook login rather than just facebook.com, unsuccessfully loaded a couple links with the same issue, then tried to load up the mobile website. That didn’t load, but didn’t redirect me, and from that point on facebook works as expected. I didn’t even have to log in, which is concerning in itself, but that’s a different problem for another day.

I appreciate your time and assistance! Have a good evening.


#9

I just realized that another difference between my experience and @adamrust is that I have two factor authentication enabled. Could that have made the difference, @Mattches?