Sites unusable in brave

I’m trying to make Brave my default browser, moving away from Chrome. I’ve found a few sites that I visit regularly are simply unusable within brave for differing reasons. The most recent ones are Verizon Wireless errors out with “ERR_TOO_MANY_REDIRECTS” and a “Business PLUS” site where the iframes (??) are displayed poorly. I’m not a web site developer, so if I’m naming certain site elements poorly, please forgive me. I’ve tried each site with the “Shields DOWN” setting, but no change.

Each of these sites loads properly in Chrome & Firefox

What does a browser developer need from a humble end-user to better the product? Or do I simply resign myself to using Chrome/Firefox for those sites?

For Verizon

  • Does it error out when you attempt to login, or when you simply try to visit the site? In either case, can you try and visit/login using a Private browsing session (or Private w/tor) and see if you get the same message?

For "business plus"

  • Can you provide a link to the page where you see this behavior so I can test on my end? Off-hand, this generally happens when Device recognition and/or Cross-site tracking is blocked – depending on what the iframe container holds.

For Verizon
It errors after attempting to login. Same with the private session attempt.
With private w/tor, I’m able to complete the login process, but there are other issues with the site upon login.

For "business plus"
Unfortunately, I cannot provide a link to the page, as it’s an employee site for payroll, timesheets, etc.
I did see this in the page source:
// There is currently a bug with viewing EO in Safari on iOS devices. Since we can’t fix it,
// we’ll at least warn the user to use a different browser.
if (isiOS() && isSafari()) {
alert(“Employee Online is best viewed in Chrome on iOS devices. All features may not be available in other browsers.”)
Now… that alert doesn’t appear, nor do I have Safari or an iOS device to test against. Yet given the alert message inside the page source, I may be stuck with Chrome/Firefox for that site.

For Verizon (the sequel)
I have Verizon myself, so I know for a fact the site should be working. I think there may be a caching error of some kind – can you try visiting Verizon wireless, then:

  1. Click the “lock” icon image
  2. Site settings --> Clear data & Reset permissions
  3. Refresh the page when prompted – to be safe, you may want to relaunch the browser entirely.

For “Business Plus”(Part II)
Thanks for the additional details. Not being able to login/test is okay – I have a feeling we can diagnose this one regardless. Can you further describe the behavior displayed on the site? You said

  • Note that an iframe refers to an page element wherein a separate (often from an external source) document is embedded within another HTML document. For example, the following code:
		<p> This is an iframe! Kind of like looking through a window to another website --, in this example!</p>
		<iframe src="" style="height:680px;width:500px;" frameborder="1"></iframe>

produces the following web page:

Now – on your business plus website, does this accurately describe the kind of page element you’re having issues with? Regardless, can you further describe what appears “incorrectly” on the page?

For Verizon
Cleared data and reset permissions for…
closed the browser, reopened browser
login attempt to Verizon site
same redirect error at

For "Business Plus"
I believe that this shows an iframe element inside a table element (I could also be very wrong in how I’m reading this).

On the left side is the website in Brave, on the right is the website in Chrome.

Hope this helps.

Can you tell me which extensions you currently have installed in Brave? I see Honey, Grammerly and a few others in the screenshot you provided.

Looking into Verizon further – very strange. Will get back to you on this.

  • If you’d like, there’s one more test you can run here – try creating a new browser profile with no data and logging in.
    Use the “People” icon on the top right --> Manage People --> Add person, then visit Verizon wireless and see if you’re able to login. Let me know what shakes out.

As for the Business site – lets try a test:

  • Try visiting that page with Shields Up, clicking the lion icon to reveal the Shields panel, and change the Device Recognition setting to Allow all Device Recognition?

I appreciate your patience as we troubleshoot this – again, I’m almost certain that both of these issues can be resolved.

I appreciate your optimism that we’ll get this solved :grinning:

For extensions: Google Docs Offline, Grammarly for Chrome, Honey, Toolkit for YNAB

For Verizon
No change with a new browser profile.

For Business Plus
No change with “Allow all Device Recognition”

1 Like

Thanks for reporting back and sorry for the late reply.
Man, you’re certainly puttin’ me through the ringer here! :ringer_planet::ringer_planet:

I’m reaching out to some team mates to get another set of eyes on this – in the meantime, just to confirm, you’re not connected through a VPN of any kind are you?


No worries. I’m travelling this week and next week for work. I can’t install brave on my work laptop (this is ok), so my home desktop is, well… at home. I have no access to it at this moment, so my ability to test things for you is crippled. I might gain remote access to my home system, or I might not. I’ll be home this Friday though, regardless.

As to the VPN question: No VPN is used or harmed in the browsing of websites during these efforts.


1 Like

Thanks for letting me know – as i said previously I’ll be working with some team members to see if we can shake something loose on this issue.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.