Brave Shields Not Working?

Latest Brave release MacOS (0.68.138) doesn’t seem to block anything on certain known tracking sites with shields up.

I tried closing Brave completely and opening it back up. Same issue. Shields work on some sites, not others, including sites with known cross-site trackers, etc. Shields are definitely on. I tried turning it off and then on and they still don’t engage on certain sites. Brave indicates that there are zero items blocked or connections upgraded. Thanks for your help.

EDIT: Disabling uBlock Origin seems to have fixed it, but I’d rather not disable uBO. Thoughts?

1 Like

@screenwriter,
Thanks for reaching out to us.
uBO and Shields should work together without issue – or at least they have been. However, after testing just now on my end I do see some inconsistencies and issues cropping up when both are enabled.

I’m reaching out to the team right now for some more information on what may have caused this change – thank you for your patience.

1 Like

Thanks, @Mattches. It seems the latest version of Brave (0.68.139) fixes this. Not sure how, but it seems to work, now.

1 Like

Never mind, @Mattches. Seems to not be working again in 0.68.142. Perhaps uBO is blocking it all before Brave Shields can? Thoughts?

I believe this is a bigger issue with the Brave blocking system.

I don’t have uBlock installed on Brave, but I have observed behavior similar to what you’ve seen where Brave is not blocking things I would have expected it to.

But what I’m also seeing more often, and that’s more annoying is Brave’s blocking things when I have explicitly lowered the shields for a site.

For examples, I can no longer log in to Adobe’s affiliate program at TradeDoubler.com, I can no longer see most of the VIP point redemption and earning options on Borderlands.com, and ads are not showing on sites where I have chosen to allow ads to show. For all such sites, Chrome works fine and Brave used to work, but an update within the last couple or few weeks seems to have broken the shields.

So it seems something has changed recently and broken how shields are supposed to behave.

This is current as of Version 0.68.142 Chromium: 77.0.3865.90 (Official Build) (64-bit).

With great anxiety, I tried resetting Brave, but that didn’t fix it (and I lost half of the tabs I had open!).

But this seems to have worked:

  1. Visited one of the sites giving me problems (in this case, borderlands.com)
  2. Raised shields
  3. Toggled each option in the Shield
  4. Lowered the shields
  5. Refreshed the page and everything worked again

I was then able to log in to TradeDoubler.com again and didn’t have to repeat this process.

So I’m guessing something along the way corrupted the shields settings. @screenwriter, try what I did and let us know if it worked for you.

Thanks for your footwork on it. I tried your method on LinkedIn and uBO caught 12 items while Brave Shields caught none. Also visited Borderlands.com. uBO blocked 12 requests while Brave Shields blocked none. But if I turn off uBO and refresh, Brave Shields works as expected.

How do I replicate the borderlands issues? Visiting the main site seems to render fine (I don’t have a login)

I simply visit borderlands.com and it happens. In the attached photo, uBO has blocked seven requests on the page and Brave Shields (as indicated by the lack of badge on the Brave icon and confirmed by the subsequent clicking on it) has blocked zero.

Disable UBO and enable sheilds. Also some of the scripts won’t show up in the blocked items in Sheilds (the google-specific trackers) because we polyfill these rather than block them.

Ubo can interfere with what shows up in Sheilds, but it’s still safe to run both.

Thanks a lot for the added info, @fanboynz. You mentioned that it’s safe to run both but I should disable uBO. Speaking as a Brave novice here, does Brave Shields protect against everything that uBO does (out of the box)? What does it mean that Brave Shields no longer seems to block elements that it used to (i.e., it used to block multiple items on a site like LinkedIn and now blocks zero items/connections)? Is it just uBO addressing the blocking first, in some sort of load order, leaving whatever’s left to be blocked by Shields? Thanks for your insight.

@screenwriter,
From my testing this seems to go both ways – there are times when both are enabled where Brave will catch/block the majority of unwanted content and then vice versa for other sites. I would also recommend retesting today, since we released a rather hefty update today addressing a lot of issues.

@DanielJLewis,
I was just able to visit borderlands.com with default Shields settings and navigate the site without issue:

Thanks, @mattches. I just updated and am seeing the same issue. uBO catches most if not all, and Brave Shields catches few or none. Maybe uBO’s filters have recently been updated to block more and ahead of Shields? When I tried cnn.com, I noticed that with uBO activated, it caught 50+ and with uBO deactivated and Shields on, Shields caught 30+.

Comparing UBO vs Sheilds,

  1. 1st-party items are fine, we’re don’t block them by default (We are investigating an option to allow users to block 1st-party items too)
  2. There was a bug where we whitelisted a twitter tracker in error, which I’m attempting to fix.
  3. Some items are polyfilled (googletagmanager/google-anaylytics/mostly google stuff), these items might not show up
  4. If you allow the embedded social media in sheilds, this would sway the blocked items numbers in sheilds also.

I hope that helps :slight_smile:

Thanks for the info. I don’t allow embedded social media posts in Shields from any of the options (Google, Facebook, Twitter, LinkedIn). This isn’t a dealbreaker for me and Brave by any stretch. Just wanted to see if this was expected behavior or not.

Doh! I had a detailed reply about the Borderlands website issue, but it didn’t work through email, and now I can’t find that message.

Using https://borderlands.com/en-US/vip-activities/ as an example (after logging in), none of the activities would display. Looking at the HTML showed those activities are loaded from crowdtwist.com, which probably hosts a lot of things Brave shields would normally block. But even if I visited that domain and lowered the shields, things still wouldn’t work back on the Borderlands site.

This same issue showed up throughout the Borderlands site, wherever there was CrowdTwist functionality, like redeeming codes, claiming rewards, and earning points through activities.

I tried deactivating all my extensions. I tried an incognito window, I tried resetting Brave. Nothing worked until I follow those steps I shared above to toggle each option in the Shields pop-up.

After doing that, the Borderlands site behaved as expected, and then so did other sites, including TradeDoubler—even without doing anything further with my shields.

So it really seems like the shields’ global settings were corrupted, but toggling them fixed them.

@DanielJLewis - With uBO on? I’ve tried toggling Shields, un-toggling Shields, refreshing the page, and such. No dice. uBO seems to be doing the job, so I suppose that’s all right. Brave Shields seems to catch some things on some sites, just not as much as it used to (unless I turn uBO off). My guess is that uBO is simply loads before Shields and blocks items first, then Shields has a crack at it and blocks whatever uBO misses.

(Ugh. The reply by email thing seems to be broken.)

I don’t use uBO on Brave. But about the toggling, I’m not saying to simply toggle the shields, but toggle all the options in the shield pop up.

I’ve done that. Toggled Cross-site trackers, Connections upgraded to HTTPS, and Scripts blocked. On, off, on, off, and on again. No dice. If you’re not using uBO, then my guess is it’s a uBO/Shields issue. When I turn uBO off, Shields catches a bunch.