SOLUTION ! Brave browser BLACK screen FLICKERING FIX ! with the hardware acceleration ON!

Driver for integrated graphics card - manufacturer versions must be installed.
If you messed up with updates over the manufactured version.

If thats done;
RIGHT CLICK ON DESCKTOP SPACE/ DISPLAY SETTINGS - PROPORTIES/ BOTTOM - GRAPHICS SETTINGS/ EXPLORE - ADD PROGRAM BRAVE BROWSER/ RIGHT CLICK/ CHOOSE INTEGRATED CARD SAVING MODE.

SETTING IN INTEL CONTROL PANELL

  • IN DISPLAY MAX RESOLUTION REFRESH RATE
  • 3D SETTINGS -
    CUSTOMISED SETTINGS
    VERITICAL SYNCHRONISATION ( HARWARE )
    ANTIALISAING MORFOLOGICAL - I HAVE 3RD OPTION OFF, SECOND ONE IS OK TOO

laptop GL52VW

integrated intel HD530 - Asus driver software must be !! ( expecting that rule applies to all laptops with 2 graphic cards)

dedicated Geforce GTX 960 M from
https://www.nvidia.com/en-gb/geforce/geforce-experience/ - can be newest one .





2 Likes

This is similar to my issue but I can’t figure out the results as they don’t match my Win 10 settings.
Mine is random. It only happens when I use Brave. The web screen area goes black, then sometimes it makes the whole screen black because I can’t even see the bottom task bar, but then, it comes back on. It’s so annoying. I keep having to go back to using Chrome of Firefox just to not have to experience that.

2 Likes

try to uninstall graphic card if is laptop both integrated and dedicated completly. Then install recomended udated from manufacturer. It helped to me.

1 Like

Yes, it’s a laptop. I will try that. It bothers me that everything else is working and all others such as firefox and chrome are working great. So having to do this for just BRAVE makes me think that it might just screw something else up, but I will give it a try once I find the right update just in case I don’t like the automatic ones.
Thanks again for the suggestion.

2 Likes

yeah flickering espesially when you have external monitor or not i have got asus GL52vw
with external monitor.

Seriuously ive had to install intell hd 530 integrated video card drivers from Asus
Nvidia as dedicated i can have updated new versions.

But my issue was bad as completly screen was switching on and off very fast randomly when was browsing watching youtbe etc. Same and even worse was on Monitor connected to HDMI. But . only max refresh rate i was able to get was 60 HZ
when monitor is 144 samsung odyseeye 3g .

After uninstalling main graphics driver (updated one) which was in mine asus Intel hd 530
and installing from Asus.
I was able to switch to refresh rate on external monitor to 120 hz
of course i have got old Intel Controll Panel.
But Better compabillity.
Plus no more flickering.

1 Like

Thanks. I have a 15" LG Gram and a MSI external monitor connected via HDMI. Never had an issue until I started using Brave. Not that Brave is good at research. I often have to do the research via Google since the Brave one gives me weird links or not the links I need. So I end up going to Google Chrome or Firefox anyway for those. Only reason I went to Brave was because I got tired of those locator ads that follow you once you’ve looked at their sites.

2 Likes

brave is bad with thubnails not appearing sometimes this is what im experiencing. The flickering issue is because of drivers in my case Intel Hd 530 integrated ones newst ones not good.
only ones from my manufacturer ASUS.
Fix all isues with Screen Flicering switching on and off.
But thumbnails issue sometimes comes on you can see in my profile what i mean about it.

i like Brave browser because of rewards and ad block intergrated also because it looks same as googe.
it is much better in this case than anything else in my opinion.
But not perfect glitches happens LOL :frowning:

1 Like

Yes, this works for AMD too. Setting AMD integrated graphics only, for power saving, eliminates the flicker. You lose performance of graphics switching, though.

The monitor refresh rate may be another issue for some people. My computer has 144hz refresh. If I set it to the normal 60hz refresh, I don’t need Brave Browser to run under the power saver integrated GPU setting.

Chrome, Chromium, Edge, or other builds simply don’t have this problem at all, and there have been no explanations why. My guess is some sort of fingerprinting mitigations.

2 Likes

UPDATE: I was wrong about my guess.

Other builds of Chromium only use integrated graphics by default, at least on my machine. Brave is the ONLY one that uses switchable graphics. I tested this using the task manager under the Performance tab. Brave uses both GPU 0 and GPU 1. Other browsers like Edge only use GPU 1.

1 Like