Brave Browser Flickering

Hello everyone. If you use a search engine to search for “Brave flickering” you can see that the issue is around here since 2021 for some users.

The things I tried to solve the issue:

  1. Disabling hardware acceleration on Brave settings (When I do Brave starts using too much CPU - Hits %30 and keeps it around %15-20)
  2. on brave://flags - set OpenGL and Vulkan as “Enabled” (My laptop has dual GPU and solved the issue but I don’t want to Brave use my performance card because my fans start running faster. Also, only enabling vulkan or OpenGL not solving the issue)
  3. Which I choose to it. On your computer’s settings: Graphic Settings> Brave> Options and set it to run only one GPU instead of letting the Windows handle it option. I chose AMD and the issue is solved without more CPU usage.

My device specs:

Processor AMD Ryzen 5 5600H with Radeon Graphics 3.30 GHz
Installed RAM 8.00 GB (usable: 7.36 GB)
System type 64-bit operating system, x64-based processor
2nd GPU: Nvidia GeForce 3060
OS: Windows 11 Home

Drivers are all updated

Same issue on me!

As far as I understand this problem occurs in systems with 2xGPUs. I’ve another PC, a desktop, with one discrete GPU, and there is no problem at all! While this issue appears on laptop which has AMD/NVIDIA gpu. At the moment I have also solved it by dedicating to Brave only AMD graphic.

Still waiting for this problem to be solved permanently.

Brave: Version 1.57.49 Chromium: 116.0.5845.96 (Official Build) (64-bit)
System: Windows 11 Pro, 22H2
GPU #1: AMD Radeon (Renoir) [HP]
GPU #2: NVIDIA GeForce GTX 1660 Ti [HP]

I’m also getting the same issue , it happens on brave only and not firefox. Typing in textboxes also causes the text to flicker and it feels not stable as they characters are no registered as well as in firefox

1 Like

I have the same issue if by flickering you mean the window goes black for a few seconds. It’s happened 5 times just today.

1 Like

I still have this issue, had it for probably over a year, it Is totally useless watching youtube videos. I’m on a MSI GS65 Stealth laptop with RTX 2070 mobile. Firefox has no issues with this. I dont think to disable hardware acceleration is a solution.

Hello guys…me too recently been facing this issue and it came as a surprise because I’ve been using Brave for more than 3 years now but haven’t really encountered this problem. Previously I was using a Lenovo Ideapad 3 with an AMD Ryzen 5 3500U and Radeon RX Vega 8 IGPU, but about 3 months ago I upgraded to a Lenovo Ideapad Gaming 3 16’ gen7 laptop with an Intel I7-12650H(Intel UHD Graphics IGPU) and an RTX 3060, and I assume this issue comes as a result of a dual GPU setup. What I would recommend is switching the application to use only the integrated GPU as it might help resolve the problem, preventing potential conflicts between the dedicated and integrated graphics card.

Go to → Settings, System ,Display, scroll down and find Graphics, and Browse the application(generally is found on your Windows:SSD Program Files). Select it, then click the Brave Browser application that will show up and click Options…and choose your processor’s IGU as the preferred graphics for the application.

Let me know if this method helped to resolve the problem. <3

2 Likes

I still need to test it more, but apparently it worked, thanks!


i have these options??Q?? wht do i pick

This worked for me very well. Thank you.

I think is up to you. I chose the power saving one. It solved the issue

1 Like

I changed it to power saving but it still flickers.

This is the actual solution. Turn off analysis for brave only. The image here is how to do it for nvida. Not sure about other video cards.

IF you turn off hardware acceleration you disable getting the max out of your videos. Try this first.

Now there might be a setting in analysising that you can still keep it on, yet didn’t want to spend the time checking every single one.

It’s not just flickering for me. With Hardware Acceleration turned on if I put 2 windows up side by side they will copy each other. The left screen will start displaying what is on the right and vice versa. It’s very trippy and makes you wonder if your browser activity is being tracked.