Frequent flickering of the whole brave browser window!

I was having flickering issues of YouTube videos when hardware acceleration was turned on in the advanced system settings. Whereas, if I turn off the hardware acceleration the flickering is gone but I cannot use some creative web apps like Figma or related apps smoothly. The prototype section of the Figma suggests to turn on hardware acceleration for the proper functioning of the prototype view.

I have also read other topic with the similar issues and applied them like switching “brave://flags/#use-angle” from default to OPEN GL, turning the Vertical Sync (VSync) option off for brave browser in the NVDIA 3D settings.

When I was using brave after switching use angle from default to OPEN GL, I was having problems with opening multiple tabs and windows, playing You Tube videos. You Tube was suggesting to restart the browser if the video content doesn’t play shortly.

I have a NVDIA GTX 1650 graphics but at default the system was using the integrated i5 9th gen processor, therefore firstly i changed that to NVDIA processor and turned the VSync off in the NVDIA control panel - 3d settings.

Previously only You Tube videos were flickering but now the whole browser window flickers at frequent rate. And this has caused so much frustration while working in this browser. Other browsers like edge or chrome doesn’t flicker at all.

And also, brave takes much time to start than other browsers and sometimes when opening brave my laptop fans get crazy. After all these problems now I think I’ll change my browser preference if I don’t get to fix this problem. If anyone can provide me any solution for this except the solutions I mentioned above ???

1 Like

Hi and welcome to the community. :slightly_smiling_face:

I was hoping a tech savvy community member would pop in and offer suggestions… I am definitely not tech savvy but thought I would post some information that may or may not be related. Please excuse if none of this is helpful or if it is something you already tried. I am hoping some of it might be helpful!

It would probably help other community member, or Brave support staff, if you could post both your Brave and OS versions. You can copy and paste the information from brave://version. Also, you may want to confirm that your Brave and OS versions are updated as well as your drivers (I’m sure this is the case, but threw it out there anyway :stuck_out_tongue:).

This is an older article at Brave GitHub Wiki, but it may give you some ideas.
GPU issues incident reports

An older Brave GitHub issue report that may provide some insight. You may want to search issues on Brave GitHub if you haven’t already. I tried but gave up. I couldn’t tell if any of them applied to your issue or not. :laughing:
[Desktop] After sync v2 upgrade, seeing High GPU util, potentially some OOM Kills, Screen flickering and freezing up (when Grammarly extension enabled) #11412

I think you already tried this one

This was another post in the same topic that may offer some help. I couldn’t tell…

These may or may not be related to the fan issue… you might want to do a search on community topics and GitHub to see if you can find more information. Again, I tried but just can’t discern what is actually related to your issue.

1 Like

Hi

@Rohan2 I have nvidia GTX 1660ti, I7 9th gen, Intel UHD 630, Windows 11. Never had an issue with graphics. My settings (image below) might be of interest to you.

Nota Bene: in brave://flags/ , I have smooth scrolling disabled.

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.