My screen is flickering black periodically

Description of the issue:
My screen seems to flicker black somewhat and I require assistance to getting rid of it. The problem goes away if I turn off hardware accelerator. But I need it on for a Browser Game I play. So I need to solve this issue without turning off hardware accelerator. I’ve also noticed this in the brave://GPU section of my Brave Browser. Maybe it can help you to help me solve this issue.

How can this issue be reproduced?

  1. Having on Hardware Accelerator seems to be the only way to “reproduce” this issue. But overall, or other than that, i’m not sure.

Brave Version( check About Brave):

Version 1.46.134 Chromium: 108.0.5359.94 (Official Build) (64-bit)

2 Likes

Hello there @Radon please accept my apologies for this inconvenience. Could you please try opening your main profile in private or guest mode to see if the screen no longer flickers? If the issue does not happen, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.
Regards.

Why disable my extensions though? I do need them.

Though ill try using Guest mode for awhile to see if it happens alongside disabling extensions. Because it seems to happen randomly and not immediately.

1 Like

@Radon sometimes one or a couple of extensions may be causing some issues with some pages performance, to discard this I kindly suggest you temporarily disable them to see if the issue lies there.

Be waiting for your response.

1 Like

I went on a guest browser like you said, but still encountered the flickering. These flickering seem to be at random intervals. Either coming sooner or later.

1 Like

@Radon on that case please go to brave://flags/ and search for Vulkan, try turning it on or off to see if the flickering no longer persist.

Let me know if that works.

So upon turning it on, it blackened my entire browser, flickering even harder. When I dragged it across tabs, it had a large black outline around it.

Currently, I am testing it with Vulkan turned off.

Alright I noticed that it just flickered again with Vulkan off. Turning Vulkan on made it immensely worse to the point where nothing was viewable.

When Vulkan is off, its also like when it was on Default. The flickering is very infrequent, but it happens at random times.

1 Like

I think it crashed my laptop awhile ago.
crashed

1 Like

I can see that while I have 3 tabs open, the Task Manager shows that its using 37-40% of Memory.

1 Like

@Radon could you please provide me with the crash ID from the report in order to further investigate?

I can’t seem to retrieve it. It says nothing is there.

When I redownloaded chrome, and applied hardware acceleration, the screen flickers wasnt on that browser. Chrome feels eerily and slightly slower than the Brave Browser though when im playing my browser game. Perhaps when im surfing the web too. But there’s gotta be something that seems to be going on which results in the screen flickering.

If Google Chrome’s hardware acceleration isnt causing screen flickering but the Brave Browser is, then it can’t be that. It looks to be something else.
(The chrome browser also had all of my extensions as well when I was using it at the time).

1 Like

Hi again, could you please try installing the Beta or Nightly version of Brave to see if the issue persist on those versions?

Be waiting for your response.

So for awhile, I have been using the Beta version, and the screen flickering still persists. I feel like when I tried to shrink the window at one point, it started to do so.

I had a similar issue on this post, as when I turned on Open GL, something far worse happened to my screen and there was massive tears everywhere.

Unfortunately though, the advice didn’t work out for me and I resorted to doing a factory reset on my Laptop. However, the issues still persisted.

An example of the Open GL thing being enabled in the Flags section would be this. Screen tearing as the video is playing. And screen tearing on websites.

https://streamable.com/7k3bgf (using this link to show it because there isnt enough space to post it despite it being like 11 seconds.)

https://streamable.com/okndcr (same with this)

1 Like

have you tried uninstalling graphics card driver using iobit uninstaller and clean installing the driver again ?

1 Like

I’ll give that a shot. I did update it before, but I can try reinstalling it.

1 Like

make sure you also perform restart before testing the browser again. Restarting will fix many issues and it’s good.

1 Like

@Radon let us know if reinstalling helped you resolve the issue you are experiencing.

Sorry about that, while I was using the browser I was still dealing with the same flickering. Though at the same time, the browser wouldnt end up crashing which would result in a report being made. So im just lost…

And regardless of any restarts being made, it still didn’t work out.

@scavxo

1 Like

Does the issue persist if you change the theme to Light ? To check that go to brave://settings/appearance > Brave colors > Light. Also if you have any themes installed on your device please uninstall them to see if the issue solves.