Sketchfab.com WebGL 3D Model Viewer Not Working in Brave Desktop

Description of the issue:
Brave browser fails to allow the Sketchfab.com 3D model viewer to load its shaders properly, causing it to display an error “3D/WebGL context error.”

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)
Yes.

Does the site function as expected when Shields are turned off?
No. Turning the Shields off does not allow the 3D model viewer to function.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No.

Does the site work as expected when using Chrome?
Yes, and the Chromium based Microsoft Edge (Version 86.0.622.51 (Official build) (64-bit))

Brave version (check About Brave):
Version 1.16.68 Chromium: 86.0.4240.111 (Official Build) (64-bit)

Additional Information:
Based on developer console output and WebGL tests, this appears to be due to the Brave desktop browser not supporting high precision floats and ints for the vertex nor fragment shaders. See here: https://webglreport.com/ Brave desktop browser shows mediump float/lowp int or 0 float precision for vertex and fragment shaders.
image

The Chromium based Microsoft Edge by contrast shows highp float/highp int or 23 float precision.
image
I suspect this is an anti-fingerprinting measure in WebGL, but it persists even when fingerprinting is allowed in the Shields or the Shields are turned off.

1 Like

Hello @AnthonyANI

could you check this @fanboynz i have the same experiance as he mentioned

and have a nice day both of you

Hi, sketchfab team member here, seems latest Brave release breaks WEBGL support

We use the result of gl.getShaderPrecisionFormat to determine webgl shader user precision support, without valid return we cannot decide which precision to use, and using the lowest possible as default isn’t an option either, as it would mean degraded quality for user with capabilities that could give high quality.
Seems that in latest brave we cannot get any result on that call

3 Likes

Hello, @paul_sketchfab. I’d like to look into this promptly for you; what’s a good test page to use during our review? I suspect this could be due to our farbling; but that shouldn’t be an issue if the shields were lowered.

Hello @sampson

for a weird reason when i check the site with fingerprint to strict it work fine despite the setting for the tracker

if i set the fingerprint to standard or allow all or even turn shield off it does not work

tested with new empty profile

hope that help and have a nice day

Hi @justsomeone1,

It looks like setting the fingerprinting shields to strict actually causes Sketchfab to use a fallback viewer that doesn’t involve WebGL. While it at least allows for some viewing of the model, it’s actually not using WebGL at this point and is instead using a set of JPEG images. Still a good catch!

1 Like

thanks @AnthonyANI for explaining and have a nice day :slight_smile:

1 Like

Hi Sampson, another Sketchfab team member here. Any 3D model page should do, here’s a good starting point for finding some great models: https://sketchfab.com/3d-models/staffpicks Let me know if you need anything else to hunt this down, thanks for your help with this!

@AnthonyANI correct: if we detect any WebGL issues we’ll use the fallback pre-rendered sprites.

3 Likes

I think we might have found the issue; working with the team now to file and fix.

5 Likes

We have a similar issue with our 3D rendering (on Brave Android) after the most recent update on 11/2. The rendering shows degraded quality. It looked fine yesterday. You can test it yourself by going to kanvakicks.com on Brave Android.

We found the issue; looks like a recent commit failed to wrap the farbling in a conditional check to see if fingerprinting was permitted or not. We’ve produced a test build and confirmed that it resolves the issue; expect this to land in a forthcoming build soon :slight_smile:

6 Likes

The problem is still present on the web browser (android). Sketchfab works perfectly fine on chrome. Brave version 1.16.74.

Hello @Laguna_Apel

they did not release the fix yet for the release version

also check the github link mentioned above

hope that help and have a nice day

Hello!

I think this issue affects all JS applications for a GIS/mapping company called Esri. When opening our applications in Brave, we get an error in the console:

“WebGL support for high precision fragment shaders is required but not supported.”

I can reproduce this on the Brave Beta as well. Hopefully your fix addresses our issue too! Here is a link to a CodePen where you should be able to reproduce the issue. I do not run into this issue on any of the other browsers (Chrome, Firefox, Safari, etc)

Can you give an indication of when this fixed will be released? The natives are getting restless :wink:

Got an browser update on my phone today but the bug is still happening. It’s very annoying and force me to use another browser. I don’t really get why it takes so much time to test and merge the fix but I assume there are other, more important bugs, that annoys other people more than this one annoys me.

Just updated my browser and it fixed. Thanks, guys.

Phone or desktop? My desktop browser hasn’t updated and Sketchfab is still not rendering.

Hi there, PHONE - Android.

I can also confirm that on Android the graphic glitches are fixed