3d not working in Brave

Description of the issue:
When opening a website containing 3d parts, those 3d parts do no work.
Here are some examples:

How can this issue be reproduced?

  1. Open a website with some 3d in it
  2. Appreciate an empty space where the 3d should be

Expected result:
I’d expect 3d stuff to work just like on other modern browsers

Brave Version( check About Brave):
Version 1.61.120 Chromium: 120.0.6099.234 (Official Build) (arm64)

Additional Information:
I’ve been using Brave since 2020 and 3d stuff never worked.

@unlucio I’m going to ask you a few things.

  1. Can you share a screenshot of how things do appear for you?

  2. Does disabling Shields change anything?

  3. If you go to brave://settings/system and turn off the toggle for Use hardware acceleration when available, do you see any changes?

  4. Does this happen also in Private window?

  5. Could you add a new profile and test? This will create a secondary profile with default settings and no extensions. Don’t make any changes and try to use directly.

Hello Saoiray,
thank you for your help:
Disabling the shield did solve the problem, moreover relaxing the fingerprinting block from “aggressive” to the regular one made the 3d boxes work.
Thank you for the suggestion: I never lower the shield because I really really really really (really) despise advertising (and marketing in general), so I’d rather renounce using the website than run the chance of being marketed at.

As I’m not keen to be profiled and fingerprinted as well, would reporting the broken site help?

Thank again for your help.

This definitely would be enough to cause the issue. This tends to break anything relating to fonts and a lot of special details. It has always been recommended to only turn the fingerprint protection to aggressive on a per site basis and only as needed. In general, you don’t need it set to aggressive/strict.

In fact, Brave has actually announced they are getting rid of this setting. If you haven’t seen that announcement, you can read it at the link below:

So for now, I’d recommend you adjust to adjust your fingerprint out of Aggressively block fingerprinting and you should see improvements all around.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.