My browser is not supporting WebGL

HI ,
I am recently started using brave but this problem occured that when I use Google Meet and turn on background effects ,it shows that it requires WebGL, Then I tried to troubleshoot this problem to the google support but from there I got the link to check if my browser supports WebGL or not , I checked it and shows that my browser supports WebGL but it is disabled , So Please Tell me how to Enable WebGL in brave ?
I have also attached the picture for the same.
Kindly try to solve this ASAP

Do you have fingerprinting protection set to Strict? Just so you know, that affects WebGL and don’t let it work, properly.

no I have set it to just block fingerprinting AND after allowing fingerprinting it still didn’t work
Please try to solve this fast

What’s the link google gives you to check WebGL?

Well, fingerprinting set to strict is the only reason that WebGL is affected.
You can’t really disable WebGL unless you use the adblocker, which in that case you need a specific rule, in other words, it is impossible for the average user to disable WebGL.

You should test lowering your Shields as a test first and see if it works.

How old or new is your GPU? because you can try to update your GPU drivers. What OS are you using?

But WebGL depends on your videocard, you should go to brave://gpu and see if something is not supported as it should, so it should look something like this:

image

If the GPU is too old and doesn’t appear to support hardware acceleration, you can enable the Hardware Acceleration by this flag brave://flags/#ignore-gpu-blocklist

if you go to here, do you see the WebGL aquarium working? https://webglsamples.org/aquarium/aquarium.html

There is not much to do, it is all about your computer, GPU. Maybe an extension you have is not allowing webgl to work properly or maybe Shields and especially fingerprinting protection set to strict which doesn’t let webgl to work as it should, but normally and by default, webgl should ‘just work’.

Google gave me this link- https://webglreport.com/?v=2
and I can see the aquarium in the link you gave
and here’s the report

Graphics Feature Status

  • Canvas: Software only, hardware acceleration unavailable
  • Canvas out-of-process rasterization: Disabled
  • Direct Rendering Display Compositor: Disabled
  • Compositing: Software only. Hardware acceleration disabled
  • Multiple Raster Threads: Enabled
  • OpenGL: Disabled
  • Rasterization: Software only. Hardware acceleration disabled
  • Raw Draw: Disabled
  • Video Decode: Software only. Hardware acceleration disabled
  • Video Encode: Software only. Hardware acceleration disabled
  • Vulkan: Disabled
  • WebGL: Software only, hardware acceleration unavailable
  • WebGL2: Software only, hardware acceleration unavailable
  • WebGPU: Software only, hardware acceleration unavailable

To just let you know that I have used chrome also , so there it works fine but I use brave to be just safer


I have also attached a screenshot about the link you gave
here is the problems detected

Problems Detected

  • Gpu compositing has been disabled, either via blocklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
    Disabled Features: gpu_compositing

Well, it seems your GPU acceleration doesn’t work. so you should enable this flag and see if it gets enabled:

brave://flags/#ignore-gpu-blocklist

Seems like your GPU is not working great. But I don’t know your GPU or Operating System, but that flag might work and give better performance and features.

which is weird if you say it works in Chrome but not in Brave. I mean, it still runs as ‘software’ and not hardware. So that’s why you can see the aquarium but I guess you should be able to get the Google Meet effects just as with Chrome.

Unless the problem, since Chrome is close source, Google tends to use their own APIs and crap to force you use Chrome for a ‘better experience’ too.
I don’t have a google account to test it, though so I can’t say if that’s the case.

But as you can see the aquarium it means WebGL works, not great but works.

Where does it says your WebGL is disabled in the webglreport?

I would still test disabling Shields in Google meet. Just in case.

Ok , What is the name of this flag you are referring ? as in the site (brave://flags/#ignore-gpu-blocklist) there is nothing named GPU acceleration.

Treat the flag as a link and just copy and paste it to the address bar and hit enter. or you can search by ignore-gpu-blocklist or any of those words usually GPU will give you that flag as first result.
Then you go to Brave://gpu and check to see if it says hardware acceleration is enabled

ok, I have tried that after enabling “Override software rendering list” i have checked it but still GPU composting is disabled

Well, I don’t know, what OS do you have and what GPU? If you are on Linux then enabling hardware acceleration is more complicated, I remember doing it last year when I tested a linux distro, on Windows it should work.
If your GPU is not too old, then you should update drivers. If you are on a dual gpu laptop, you should make sure the OS is picking the better one.

I mean, it is not normal your GPU doesn’t support Hardware acceleration unless it is really old, I still have a 2015 laptop but last year when I used it, I only needed to enable that flag and then I got the hardware acceleration.

I mean, you can open Chrome and go to chrome://gpu and see if it is enabled there, compare text, in GPU page when you scrolldown, you just need to find Driver Information, and you should see the difference there.

If not, you would have to use Google Chrome for Google Meet, because if it works it works and you should always search for the best experience as well.