Intermittent Problems with WebGL Build in Brave

Good Morning,

I am building out a small Unity WebGL demo that works in Chrome and Edge but is showing errors during the Unity load screen with Brave version 1.65.123.

"
Unable to load file Build/Early_Days_Build_V0.1.framework.js.gz! Check that the file exists on the remote server. (also check browser Console and Devtools Network tab to debug)

"

https://orchidxmachina.io/early-days-demo/

The errors are the same with Brave Shields on or off, and worth noting other WebGL games do work in this copy of Brave browser, including games from itch.io. It’s just this builds on my server.

I’ve gone through all the possible fixes I can think of with server admin and since it works in Chrome but not brave they’ve now suggested I reach out here, and I’m at a loss since the error message it is showing is clearly not correct if files can be found and is loading correctly in Chrome.

If you have any thoughts or feedback it would be appreciated.

Thank you,

b

What error are you seeing?

https://orchidxmachina.io/early-days-demo/ loaded okay here. Did a quick side-by-side comparison with Chrome, seemed similar in its rendering.

Shields/Fingerprinting may cause some issues with webgl

If you’re seeing an active WebGL “game” that after loading looks something like this:


then that’s good news but when I load the page from Brave I’m still seeing:


Since turning Shields on/off yields the same results, for me at least, I’m not sure what’s breaking the page in Brave, but if you have any ideas, I’m happy to have any advice or thoughts that might help me fix the build to work-with Shields on, especially.

Thanks,

B

Just as an update, I switched my build to .brtli and still got literally the same error “.js.gz, etc.” which, since I am no longer hosting .gz files shouldn’t be showing at all…so, cleared the cache from Brave browser and the problem is now fixed.

I’d already done that recently but not sure about the timeline, so unclear if switching the build to .brtli helped or if it was just the cache loading an outdated build. Either way:

Thanks for your reply. It helped me down the right path.

I’ve only been testing on Windows, so out of the box on Windows the webgl samples worked. But good to see its working

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.