WebGL not working

Description of the issue: I am trying to work on Figma.com which requires WebGL. I am getting an error there that WebGL is not available. I have followed their troubleshooting article which didn’t help. Had to open Firefox to be able to work…
How can this issue be reproduced?

  1. Go to figma.com
  2. Create a new project

Expected result: Should open graphical interface for editing projects.

Brave Version( check About Brave): 1.29.79

Additional Information:

2 Likes

I know that the privacy team is working on WebGL stuff that concerns the fingerprinting protection of Brave Shields.

Could you check whether disabling the fingerprinting protection of Brave Shields allows you to work on that website as expected? You can do that via the Brave Shields icon in the address bar.

CC: @fanboynz

Hi Rethanis,

just tried it, still not working. The error message:

Uh oh… we can’t open that file
We can’t open this file because WebGL isn’t supported, or is disabled, in your browser. If your browser supports WebGL, check out this help article to find out how to enable it.

I’ve had this issue where a game that uses WebGL just stops working completely until I restart the browser. Most of the time it’s related to the GPU Process crashing and hardware acceleration being disabled. Have you tried looking at brave://gpu and seeing what it says? The past couple of updates seem to have broken the GPU Process, so this could be a related issue.

Indeed, my report says:

Graphics Feature Status

  • Canvas: Software only. Hardware acceleration disabled
  • Compositing: Software only. Hardware acceleration disabled
  • Multiple Raster Threads: Disabled
  • Out-of-process Rasterization: Disabled
  • OpenGL: Disabled
  • Rasterization: Software only. Hardware acceleration disabled
  • Skia Renderer: Enabled
  • Video Decode: Software only. Hardware acceleration disabled
  • Vulkan: Disabled
  • WebGL: Disabled
  • WebGL2: Disabled

The last couple updates have been disastrous. In addition to this problem, my passwords don’t get saved, and my sessions/cookies/local storage won’t persist. A browser restart helps with the persistance.

I don’t want to go back to FF but if such updates keep coming out without proper testing, I will be forced to do so.

@navi,
If you have Hardware Acceleration set to Enabled do you still get the same results?

Yes, hardware acceleration was turned on all along.

@navi,
Its shown as disabled in the gpu report you shared above.

I know. All I can say is that “Use hardware acceleration when available” is turned on. At the same time that is the report I get showing WebGL disabled. Should I try with a reinstall?

It might help – before we go that route, can you tell me if you have any extensions installed? Additionally, can you go to brave://gpu, make a copy of the full report and send it to me as a DM so we can take a closer look?

1 Like

Hi team, I’m facing the same issue as described by the OP. WebGL has almost suddenly stopped working, even with hardware acceleration turned on. It’s working fine on other browsers like Chrome and FF. If it’s cool @Mattches, I can DM you my brave://gpu report too?

1 Like

Sent you PM with the report and installed extensions.

Same happening here. Acceleration active, but shown as disabled on //gpu. WebGL not working. Disabling shields doesn’t help.

Also seeing GpuProcessHost: The GPU process crashed! logs.

Running on Ubuntu 21.04.
Card is Nvidia GTX 1650 super.

chrome://gpu

Graphics Feature Status

  • Canvas: Software only. Hardware acceleration disabled

Problems Detected

  • Accelerated video decode has been disabled, either via blocklist, about:flags or the command line.

Log Messages

  • GpuProcessHost: The GPU process crashed!
  • [22624:22624:0913/092337.034106:ERROR:gpu_init.cc(441)] : Passthrough is not supported, GL is disabled

all my WebGL problems were fixed with V1.29.81

@Badsektor,
Thank you for confirming.
Can anyone else here tell me if updating to the latest build resolved the WebGL issue?

i should add that it fixed it for me on Ubuntu 21.04.

2 Likes

Updating to the latest build has not solved my issue with the GPU Process crashing and hardware acceleration being disabled, the most it has done is make it so that the UI doesn’t lock up on sites like Twitch when the GPU Process does crash. Besides that, the issue has remained the same: The GPU Process crashes on various sites, and after enough crashes, hardware acceleration is completely disabled.

My issue seems to be solved on the GPU front.

1 Like