Brave on iPhone not opening very basic sites with shield on or off. Immediately checking on Safari, site opens

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will be closed immediately. Repeatedly posting as such is grounds for banning.

Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:

Steps to Reproduce (add as many as necessary):

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Brave Version(See the About Brave page in Settings):

Mobile Device details

Android/iOS Version

Additional Information:

Please take some time and put a little bit more effort in your bug report. Have you noticed the template? Try to fill that out!

1 Like

Hello Leon

Thank you for your email.

Firstly let me say that I am sixty three years of age, not at all ‘techie’ and am only using “Brave” to firstly support an alternative community and secondly of course for security reasons. I do not know enough if indeed anything about ‘bugs’ to be able to classify an issue as a bug or indeed to be able to differentiate between a bug as you call it and a simply inefficient system.

So, I just asked a question being as thorough as I could be. I just wanted to know why I couldn’t access sites like my public library which are perfectly accessible on Safari. Please understand that my life is literally too short to spend it filling in templates to keep you happy. I don’t need anyone such as yourself writing to me telling me in some school teacher like manner to “ put more effort in”. Who do you think you are talking to me like that. I just want to open a browser, type in the site I’m looking for, find it and get on with my life. I’m not looking to report ‘bugs’. I’m too busy. So here’s a suggestion, why don’t I leave you to play your silly little power games and I’ll uninstall your obviously not fit for purpose browser. So now you can put more effort into having some manners and respect you little prick.

@leon0402 just please apologize and try to help @Larry2 which site please . @leon0402 it isn’t preference thing it is just helping someone with their problem

Hi @Larry2,

first off, I’m not from the brave team, just some user like you. I really like the browser and therefore I’m interested in making it better for example by telling the brave team if there is an issue like you did.
I hope you do understand that it’s quite hard to help you or fix the issue, if we don’t have any information about your actual problem.
Personally, I use Brave on iOS too and don’t experience such problems. So perhaps we have different versions installed? Perhaps I never been on those “basic websites”. Don’t know, without some details, it’s hard to help you.
If you don’t know how to find the version of your browser, because you are not at all “techie”, just say something and I help you finding it out.

If your live is too short to report a bug (or whatever this is), then you have to wait until some other report it (so it can be fixed) or use another browser.
There is no reason to be disrespectful against me. I apologise, if my request to give us more information sounded rude. It was indented to help you as normally such posts get flagged and closed immediately, because they are against the guidelines (as quoted in my post).

@Dgenies The template is mostly there to have all information needed to solve a problem, not because of preferences. With the information given, it’s not possible to help him. I’m not aware of any similar issue, therefore it’s important to know the setup and circumstances (brave version, iOs version, not accessible sites etc.), which might help to reproduce the issue. And of course it’s always essential to have a detailed description for example what exactly “not opening” means … any other content displayed? or just a “site not reachable” etc.

Hello Leon

Thank you and my apologies for disrespecting you. I do think that you were being rude by telling me to “put more effort in” although this could have been lost in translation or simply the way this community works?

Anyway, I asked a question as best I could. Part of me would say that if I was knowledgeable enough and could describe the problem as the template seems to ask me to, then I’d probably be able to fix it without help and if the community or forum deleted my question because it not asked the way it should be etc etc, then that would be fine. I’d just uninstall and use Safari. Sometimes forums and communities such as this can be a little bit condescending and I haven’t the time.

I use my local library to reserve books online, have no problems doing so on my Mac desktop or iPad but when I typed in ‘’ ( without ‘) on the phone in Brave, it apparently cannot find the server. I switch to Safari and no problem. I tried with and without the shield and still nothing. There have been a number of sites that can’t be found. When I say ‘basic’ I of course mean routine sites to me, sites that are used by the public all the time.

I appreciate that you are trying to help in a voluntary capacity and thank you for that but as you might appreciate, I don’t really have the same type of interest as you might have and just want a browser that works and if I can un- support the big giants in the process, even better.

Thank you. I apologise again for my lack of patience.


To be fair here, I think that I will leave this and revert to Safari. I’m a big fan of community but if, as in this instance, a browser cannot find sites that other browsers such as Safari and Firefox can find easily and simply, it doesn’t suit me. As I have said, they are sites that the general public, in this country anyway, use all the time and if I have to tweak this or that or spend time trying to explain why the simple tasks won’t work, I would be as quick walking to my library for example. So thank you again, my apologies for being impatient and perhaps rude. So please consider this thread or enquiry as closed and redundant and if the moderator wishes, delete it.

@larry2 I think the site is down. I just tried it on serveral devices and even safari and it is also down. it isn’t a brave thing it is the site

As I said on more than one occasion already, the site was freely available on my phone using Safari, seconds before and after trying it on Brave. The site is still not down and is working perfectly. You are incorrect. Here is a screen shot from minutes ago taken on Safari. As I said already and want to repeat, there is no point in pursuing this.

Thank you

@Larry2 No worries! Yeah it might sound a little bit rude, apologies for this.

back to your problem:
@Dgenies is right, your link doesn’t work, but with a quick search I found the one you mean
I’ve just tested it on Brave on my mobile phone (and a few other browsers) and it works perfectly fine.

If you use the above link (or google the site and click on it), does it show something like “site not available”?
As you see, the problem is perhaps related to your specific configuration. Perhaps you could be so nice (if you have a few minutes) and share a screenshot of the site in Brave (above link) along with the version you use, both of brave and of iOS. This would help the devs of Brave.
For Brave: Go to settings in brave and scroll down to the end “About us”. My version is 1.9.3
For iOS: Go to your iOS settings -> general -> info -> version. My version is 12.1.3

edit: Do you use Brave on your Mac book? Same issue?

1 Like

oooh @Larry2 the site doesn’t work without the www. the webmaster for the site has to put a redirect to www. that was the problem. I tried it with and without the www and this is my conclusion

I think there is a bit of a misunderstanding going on and I am more than willing to accept responsibility for that. Firstly to answer the question I have uninstalled Brave and now re installed so I have the most recent version which I’ve had all along because I only installed Brave for the first time last week. My phone is completely up to date. The same as yours. My part in this misunderstanding is that I am not bothering with www or other such stuff. When I want to visit a site I just type in the name of it, in this example south dublin library or southdublinlibraries. It may well be some technical addition or something missing but for me, keeping it simple, I type the letters and the site appears. Whilst as I have said, it might have whatever to do with webmasters and the like, that is none of my business because it works fine everywhere else without the www. For some reason, lack of knowledge on my part, I cannot attach the image this time but when I put in south… I am told quote “ a server with the specified host name could not be found” . However as has been suggested if I put in www. it will find it. That is fine but it doesn’t explain nor is it relevant to me as an ordinary user why Brave won’t do as Safari or Firefox. Another example is the website It will be found straightforward, however when I go to ‘search’ within the site, it tells me that URL was blocked by a content blocker. Even when I don’t have one on!! Turning off the shield in Brave doesn’t fix it!! Again this works perfectly on Safari. No, I don’t have it on my desktop. Thanks

Just so I really understand what is going on:

If you type in the full adress e.g with https: and with www. it will find all your sites?
But your actual problem then is that it’s not convenient enough? So more a lack of a feature than a bug.

Although I do not fully understand what feature you are missing. When I just type “southdublinlibraries” in Safari, it googles it. And if I use the link you gave without www it also doesn’s work in Safari.

Why don’t you use bookmarks?

  1. Go on your site (with www.)
  2. Click on the hamburger menu and then on the bookmark add icon (the most right one)
  3. Now you can open your favourites sites as they are under bookmarks easily

I hope this is what you need. Please let me know what you meant by “I just type in the name of it” … to me it sounds like safari makes suggestions based on your history.
Brave is also able to do that:

But as it’s based on your history, it works only if you have visited the page at least once (and have not deleted you history). So going with bookmarks is the recommended way

1 Like

Hi! Just wanted to pop in and comment on how nice of a discussion you’re all having here. Started out a little rocky butt seems to be on the right track – makes me happy to see :slight_smile:

Also, imo, if the site won’t load without www., then using a bookmark as @leon0402 had suggested is probably the best route to take on this (and the easiest).

It looks like you guys have this in control but let me know if I can help in any way.

I am smiling here because I would not have taken up everyone’s time just for convenience !! Nor did I consider it a ‘bug’ because that is not something as I said earlier than I am familiar with.To someone like me, probably in a reducing minority, things like bugs etc are something you find in the garden and I am more concerned that the browser just works simply.Old age !!

Yes,I can use a bookmark but I was just wondering why when I searched for something that worked before, why it didn’t work now.I wasn’t reporting a bug as such, just couldn’t get a search to work.

Now the interesting thing… to me anyway….is that when I start to type ‘south…’, the search box will auto fill and the memory/bookmark with offers me 3 options- two are the google search and the other is straight to the home site.However if I don’t take the offer and go instead for what the search box has auto filled,, and hit ‘go’, again the error comes up?? So what I am left with, and I am not complaining!! that even though Brave now has the site bookmarked, even though it autofilled, if I don’t take the memory option, the error appears. However if I just type south…in Safari without the www, it will immediately auto fill to www.south…… even though I have cleared my history on the phone???Now it not a deal breaker or a reason to call the cops but it is where I started first thing this morning. Also interesting is that when the search autofills and I hit ‘go’ what appears next in the search bar is and the error is then shown.So a “ / “ has appeared from somewhere…is that the problem?

The second problem I had which on top of the one above was that when I visited the site…as you can see I read and look for a new house!!!….the site was found no problem without a www( this is obviously something connected to the site of the library) but when I tried to define the search within that site, it refused to allow me. It said that the URL could’t be found because of a blocker.I had disabled my blocker and so discovered that the blocking was happening with the Brave shield.If I turned that off all was well.Is there a way to workaround having to turn the shield off?

Thank you again to everyone and I wouldn’t like anyone to think I was just being lazy and insisting that Brave worked to suit me for convenience.I was more concerned about why it didn’t or wouldn’t find a site and I just wanted to know why and what was I doing wrong.


@Larry2 Sorry for taking so long to respond to your message, I have been quite busy the last week!
For me it sounds like you want some kind of autofill feature (I still don’t know what you mean to be honest). Autofill is at least in my understanding convenience as well as bookmarks … as the normal way would be to just google it.
But don’t get me wrong here! It’s totally fine to ask for a convenience feature (or to tell us a bug in an already existing convenience feature) and I don’t think your are lazy or anything … I just wanted to state out that our first assumption that certain websites don’t work (which would be very critical) is wrong.
Anyway, perhaps it might be possible for you to post a video about the behaviour you want to have (so a video about safari) and about brave (how it does not work), because I cannot follow your explanation. Or perhaps @Mattches could take over here as I don’t want to waste your time just because I’m not able to understand what you mean (I’m also working a lot at the moment and don’t really have time for it)

This topic was automatically closed after 30 days. New replies are no longer allowed.