'Reopen All Tabs' worked only for some windows, not others

After restarting BRAVE, my windows & tabs for some reason didn’t open as they normally do.

I have them set to reopen in Settings but usually click the ‘restore tabs’ button when it appears on the screen at startup. (My understanding is that that shouldn’t be necessary given the ‘preset’ in Settings, but I do it anyway when I see it.)

My main question concerns the History menu’s retention of the tabs in the windows from my prior session. When I clicked ‘Reopen All Tabs’ it worked for some windows but not for others (i.e., no response to Reopen All Tabs).

Why would that happen? (None of the windows that didn’t open their tabs were Private windows.)

The real clinkers is that when those tabs don’t open they still disappear from the History dropdown menu. So unless I’ve made a note of them before clicking on ‘Restore’, I don’t even know which tabs failed to open, because now they no longer appear in the dropdown.


BRAVE Release version / Mac Mojave


The issue raised in the original post is NOT solved per the following.

However, I discovered inadvertently that when I went into the windows/tab list in TABLI (tab manager), all the missing window/tabs – i.e., the ones that were NOT displaying in BRAVE’s ‘Window’ dropdown – were there.

This is something I’ve reported in the past and that I believe points to a display problem in BRAVE following a ‘restart’ (of BRAVE) when previously-open windows don’t appear to have loaded properly.

They (the missing windows) are ‘there’ but BRAVE doesn’t display them.

Once I load them from TABLI (where they are displayed), they then also show up in BRAVE’S ‘Window’ dropdown menu.

Would appreciate BRAVE Team looking into this when possible.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.