Removing a top site removes an additional site and both are back when a new tab is open

- Description of the issue:

Top site will not be removed or will remove another top site that is on the side together with the one I want to remove.

Both sites will be back on the top site bar when a new tab is open.

- Steps to Reproduce (add as many as necessary):

  1. Launch Brave

  2. Click on the X to remove a top site

  3. The action on step two will remove the site selected and another site by his side

  4. When opening a new tab both sites are back on the top sites bar

- Actual Result (gifs and screenshots are welcome!):

Issue can be view on the youtube link (I´m a new user, so I can´t add media to the post)

The selected top site and the site next to him are removed simultaneously, and both are back when a new tab is open.

- Expected Result:

Only the selected top site should be deleted and it should not reappear when a new tab is open

- Reproduces how often:

Always

- Brave Version

Brave is up to date

Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)

- Reproducible on current live release (yes/no):

Yes

- Additional information:

I’m using Windows 10 Home.

1 Like

@Andrew79,
I’m not able to reproduce this issue on my end. Removing a top-site by clicking the x as you described works as intended on Windows 10 (version 1.10.97).

Can you try disabling the extensions you have installed in the browser (temporarily) and check to see if you get the same behavior with no extensions enabled??

1 Like

@Mattches


Still the same.
Should i reinstall?
1 Like

@Andrew79,
Thank you for testing. Can you actually try creating a new profile (Menu --> Create new profile – note that this won’t erase or overwrite your existing profile), browsing for a couple minutes (just long enough to get a couple of top-sites to appear on the NTP) and seeing if you get the same behavior when trying to remove a top-site in the new profile?

1 Like

@Mattches


It worked.
How should i procced?
Should i delete my browsing history or use another account?

@Andrew79,
Sorry for the late reply – I would delete browser history. It’ll be less work than re-configuring a new profile and I think that clearing your browsing data should do the trick.

I’m still not entirely sure what was causing that behavior but I do appreciate your patience and willingness to work with us.