ERR_CONNECTION_RESET on Brave & Chrome on Ubuntu

Description of the issue:

Brave & Chrome won’t connect to ERR_CONNECTION_RESET since April 13 2023 with the following configs: Normal mode & private mode, shield on & off, acceleration on & off, cache cleared.
Loads fine on: Private mode with TOR, Brave for Android, Firefox.
Other sites load fine.

How can this issue be reproduced?

  1. Go to

Expected result:
Normally loads

Brave Version( check About Brave):
Version 1.50.114 Chromium: 112.0.5615.49 (Official Build) (64-bit)

Additional Information:
Ubuntu 20.04.6 LTS

Hello @gammy393

you said it work with brave using tor and with brave on android ?

is your android device connect to same internet like same wifi or you was using mobile data on android?

did you tried to restart your router? if that did not help could you go to brave://settings/security and enable Use secure DNS and then from the with menu choose anyone of them maybe cloudflare

hope that help and have a nice day :slight_smile:

That solves the problem, but what’s interesting is i’m already using dnscrypt-proxy and the shows Cloudflare yet the site wouldn’t load until i switched on the Secure DNS?

enable secure dns will make brave look for the site ip throw dns over https from cloudflare (or any other option ) not throw your dnscrypt-proxy
i guess there maybe issue with dnscrypt-proxy while it try to get the ip of the site

i never used dnscrypt-proxy so try to check if there away to clear it cache and try it again

and have a nice day :slight_smile:

dnscrypt-proxy was supposed to use Secure DNS (at least with Cloudflare) for the whole OS before browsers started implementing Secure DNS. Never had any issue with it before this.

it been while since chrome/brave bring the secure dns feature but not sure any other idea that could cause it

Nope, it didn’t solve the problem. Just opened my browser and it doesn’t work again even with Secure DNS (both radio button options tried) and when turned off. Something is wrong after April 13.

could you disable dnscrypt-proxy and see if it work fine with/out the secure dns option

Everything works except Reddit on Brave & Chrome, guess i’ll just switch to Firefox. Thanks.

you welcome :slight_smile:

looks like it something related to chrome did you tried to use brave beta maybe they fix it on later version of chrome?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.