I had to use a different browser to submit this topic because Brave on Linux is having DNS resolution issues

Description of the issue:
Very often when loading new web pages or even refreshing tabs I already have open, I will get a DNS resolution error or I just get a constant progress spinner. I am not having these issues with LibreWolf which is an Un-Mozilla fork of Firefox. I could not even get to this website and had to use LibreWolf to submit this topic.

How can this issue be reproduced?

1.Load any web page
2.Sometimes it works and sometimes it doesnt

Expected result:
Web pages load as expected.

Brave Version( check About Brave):
I am using Brave on Linux:
Version 1.36.119 Chromium: 99.0.4844.83 (Official Build) (64-bit)

Additional Information:

I disabled the use secure dns setting, and I am still having the same issue.

If the page does finally load, I have a page where some artifacts do not get loaded. This happens more than the pages not loading.


Here is an example of the error page in Brave.

I do not have a proxy server configured, my internet is fine and so is my firewall and av.

Again, the same web page will load with a different browser just fine.

Yet a different error, same result.

Hello @rodericklm

what is your linux distro and version?

do you have any extension ? if yes then could you try to disable all of them and try again in private mode

if it work then either the issue with one of your extension or you need to clear your cache

if that did not help could you create new brave profile just for testing go to menu then create new profile and check it for while and see if it work fine there or not

hope one of those help and have a nice day :slight_smile:

Im using Arch with Kernel 5.15

I tried your suggestions, but the issue still exists.

The only way that I can get pages to load, if they do not load, is to toggle the site shield switch.

Sometimes the sites load with shields up, and sometimes they load when shields are down, it is not consistent.

even with new profile ?

there new version released could you update brave and check if that help

Version 1.36.122 Chromium: 99.0.4844.88 (Official Build) (64-bit)

if not then could you go to brave://components/ and check for update for all components

if this did not help also then could you change your dns or restart your router and your computer?

hope one of those help and have a nice day :slight_smile:

This issue no longer exists after the last update.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.