Recent Monthly Payouts Inaccurate

Briefly describe your issue:
I have only been paid around 2 BAT per month recently, down from 10+ per month. In April, I worked on the computer full time, can view up to 5 ads per hour, but I only received 2.38 BAT. For 10 days of May, my pending rewards are already 3.8 BAT from 67 ads, so the April, March, and February payouts seem way too low. Is there a way to see the total ads I received over those months to check if the payouts were accurate? If they are indeed too low, how to fix this?
Here is a screenshot of recent BAT payout amounts sent to my Uphold account.

What Operating System and Brave version are you using (Menu --> About Brave)?
Windows 10. Brave Version 1.24.84 Chromium: 90.0.4430.93 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no)
Yes

What date did you verify your wallet?
Two years ago, I started receiving Brave payouts to my verified Uphold wallet.

Have you been able to successfully receive payments in the past?
Yes

Are you using a VPN? (yes/no)
Yes

Are you in a supported region (see here for list of supported regions)?
Yes, USA.

Does your device pass the SafteyNet check (Android only)?
N/A

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
Yes

1 Like

I’ve noticed very much the same issue. Used to earn ~10+ BAT, but the last 2 months it’s ~1-2…

Oddly, I also just saw a ~1 BAT reduction after simply applying a Brave update that I would have imagined to be the fix that finally ports my BAT over to Uphold - which still isn’t happening.

I have the same issue. I was supposed to get 21 BATs for the month of April, as shown on the ad setting page of the browser, yet I only receive 1 BAT. @steeven could you please tell us what we need to do to fix this?

I am having the same problem. I was payed only 1-2 BAT after looking at over 180 plus ads

I have the exact same issue. Perhaps something probably went wrong this payout round.

I am hoping its that the payouts are just lagging. I was asked to DM the mod, did so, and got no response.

I am having the exact same issues, used to get about 10 BAT now only 2 BAT.

@steeven Would you be willing to assist us with this issue?