PWA causes Brave to freeze and keeps increasing memory usage (potential memory leak)

Description of the issue:

Since a few updates ago (I forgot which exactly), I can’t open PWAs anymore. Neither those created previously, nor newly created ones.

When I click one to open or select one from Spotlight, the open Brave window freezes and my cursor turns into the spinning beach ball cursor. The PWA icon does not appear on the Dock and the window is not seen either. Brave gets locked in this state and keeps taking up more and more memory increasingly, according to Activity Monitor and htop.


How can this issue be reproduced?

  1. Create PWA (hamburger menu > More Tools > Create Shortcut > Open as Window)
  2. Open created PWA (from the Application menu, Spotlight, Dock, Finder, etc.)
  3. Wait for PWA to open

Expected result: PWA opens up as usual.

Brave Version: V1.38.109

Additional Information:

My system information:

image

My PWAs:

image

PWAs were working until a few updates ago. After that, there were 2-4 more updates, and each time I expected it to get fixed, but maybe I’m the only one with this problem?

I did clear cookies and data from Brave, restart my Mac, Shutdown and start again, and I restarted Brave as well (had to cuz it froze cuz of this issue). Nothing helped.

I think it’s better to include what PWA you currently have… So that mods can check it out easily. I have these PWA in my brave browser (Version 1.38.109 Chromium: 101.0.4951.41)
and they work all fine in my end (this was windows 10 BTW, it’s possible the OS has some factor):
image

1 Like

Thanks. I edited the post to include a screenshot of my PWA list. The ones I most frequently use are Discord, Telegram, and Spotify.

1 Like

Just keeping the thread alive. This is still an issue.

@cybardev Hi and a late welcome to the community. :smiley: I am a community member too. I can’t help you with your problem, sorry. Just throwing some general steps you might try to provide more information that may help support staff.

There were previous issues with PWA crashes a few releases back which were fixed. I searched for others reporting this issue within the community, on reddit, and on Brave GitHub issues and couldn’t find anything. If you have found anything, please post an update. It will help determine if this is something unique to you or a new bug or regression that is not yet widespread.

  1. This topic is a past report of PWA issues. It has some troubleshooting steps you may want to investigate: Updating to 1.35.104 breaks all PWAs I linked the specific things to check below.

    Updating to 1.35.104 breaks all PWAs - #4 by sampson
    Action: Check for crash reports at brave://crashes. Follow instructions in post if have crash report(s). Also post the crash ids and tag the moderators in your post.

    Updating to 1.35.104 breaks all PWAs - #9 by sampson
    Action: Check to see if behavior is occurring in other Chromium based browsers. Post an update on results.

  2. Do you have any extensions installed? Try disabling extensions and see if problems still occur. You may also want to clear history/cache, exit the browser, and reopen.

  3. Create a new test profile and see if the issue is happening in a new profile.

  4. Does the same behavior occur in the Brave Beta and/or Nightly versions?

Please post an update. Be sure to tag the moderators in your update, especially if you have crash ids. Hope this helps!

1 Like

For now, I have these updates:

  • the issue happens on Ungoogled Chromium as well (installed via homebrew)
  • the issue happens on a new test profile with no extensions installed as well

I’ll post more as I test them.

1 Like

Tagging @Mattches to see if he can take a look especially since results are reproducible in ungoogled chromium and in a new test profile. May be an issue specific to your install of macOS, which I know absolutely nothing about!

Edit: You are updated to the latest versions of Brave and OS, correct? Brave release is currently 1.39.111.

1 Like

I am indeed on the latest Brave, 1.39.111.

May be an issue specific to your install of macOS

Could be. I should make a VM and see if it happens in there. I’ll post updates when I get to it.

Thanks for all your help.

1 Like

@cybardev

Been meaning to ask you, What keyboard commands (command line - command string) did you use, in order to produce the “system information” for your MacBook Air? Thanks in advance.

@289wk Oh, it’s just a screenshot of neofetch.

It’s handy for some basic sysinfo, but if you want more details, you can run the system_profiler utility, which is usually piped into grep or more.