Problem with "continue running background apps when brave is closed"


Description of the issue:
I always have multiple windows with multiple tabs open.
Which is why I need to close brave using the exit option in the menu.

Doing so also quits the background apps as the brave icon in the taskbar also disappears with the exit.

I need to have the background apps keep running when I exit the browser.

I think this might be a bug.
Please help with this.
Thanks

My brave version is
[Version 1.22.70 Chromium: 89.0.4389.105 (Official Build) (64-bit)]
(https://brave.com/latest/)

Hello @rp1231

what you mean with background apps ?which apps closed

Hi @justsomeone1 ,
I have uploaded a gif showing the icon and the app.
https://imgur.com/l1BO7mG
The brave tray icon used to show on startup previously and now only shows while brave is running and disappears when I exit brave.

go to brave://settings/system and make sure that Continue running background apps when Brave is closed enabled

try to disable all extensions and see if it work or not

@justsomeone1
I have that option enabled but having this problem despite that.

what about extension ?

Also If I disable all the extensions, then there is nothing to run in the background,
In which case the icon goes away while brave is running…

after you close brave does it show up in the task manager or not?

also are you using windows 10?

if yes then make sure that in the windows setting that brave has the permission to run in the background

It doesn’t show up in the task manager.
Could you help me with where I could find the windows setting?
It used to work fine before…
I just reinstalled windows so it could be because of that.

Hello @rp1231

check this one

https://support.microsoft.com/en-us/windows/windows-10-background-apps-and-your-privacy-83f2de44-d2d9-2b29-4649-2afe0913360a

In the link you sent me it says this:

Desktop apps won’t appear in your Choose which apps can run in the background list and are not affected by the Let apps run in the background setting. To allow or block desktop apps, use the settings in those applications.

So this setting doesn’t really apply to Brave it seems

let me ask someone from the team to check that

@Mattches brave does not keep in the background despite he enabled this Continue running background apps when Brave is closed

and have a nice day both of you :slight_smile:

1 Like

@rp1231,
I think I understand the issue, but can I ask why you need to have apps run in the background? Is it for the “Join” extension specifically? Additionally, do you have multiple browser windows/tabs open using the same browsing profile or are you saying that you have multiple browser windows up, each with different profiles?

@Mattches
Yes the reason I want to have apps run in the background is for the join extension specifically.

I currently have 4 windows open, each with multiple tabs.
I haven’t created any profiles as such.

Any solution regarding this?

I believe this is by design.

Background processes (such as those belonging to extensions with the background permission) are only persisted until the user has explicitly terminated the browser (i.e. by clicking Exit within the ☰ menu). This is the expected behavior.

Closing windows, however, is not interpreted as an explicit request to terminate the application, which is why the background processes will persist in that scenario.

Consider the following from relevant documentation:

When any installed hosted app, packaged app, or extension has “background” permission, Chrome runs (invisibly) as soon as the user logs into their computer—before the user launches Chrome. The “background” permission also makes Chrome continue running (even after its last window is closed) until the user explicitly quits Chrome.

1 Like

@sampson
The extension that I’m using is:

Also I want to mention that I started having the problem only after I reinstalled windows.
Now the brave background app doesn’t even appear on startup even though it is enabled in the task managers start up tab.

Also If I remember correctly, before I reinstalled windows, I was able to have it running in the background even though I exited brave.(Not very sure about this though)

Thanks