Private certificate do not work

I have a Mac OS running Brave [
Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (x86_64)

When I attempt to conect to a device that has a private certificate such as https://192.168.1.1 it does not give a option to connect to the device. I know this is a problem because Brave on android allows the connection to the same device.

could you send screen shoot of what you see when you go to the link you mentioned

and have a nice day :slight_smile:

Here is the message. Other browsers including brave for android do not provide the message below. This occurs with version
Version 1.22.72 Chromium: 89.0.4389.128 (Official Build) (x86_64)

192.168.x.x normally uses encryption to protect your information. When Brave tried to connect to 192.168.x.x this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be 192.168.x.x, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Brave stopped the connection before any data was exchanged.

You cannot visit 192.168.x.x right now because the website sent scrambled credentials that Brave cannot process. Network errors and attacks are usually temporary, so this page will probably work later.

i would like screen shoot

also you said

does it mean brave on android load the site but the desktop version do not

also could you disable all extension and try in private mode

Why do you want a screen shot? What are you wanting to see? The only difference is the URL which https://192.168.x.x:2434

Using Brave on Android to access the same site produces no error message

i wanted to see if there extra option like advanced button to click on it that allow you to add this as exception or bybass that warning

what about disable shield does it make it work?

and what about this step

did you tried it?

I tried disabling, Private window with Tor and Widevine then open a private mode and the same error occurred. This is on version
Version 1.23.73 Chromium: 90.0.4430.85 (Official Build) (x86_64)

did you tried this

also if it did not work could you create new profile and see if it work?

With shield disabled the problem still occurs. I found another example. If I go to the web site https://www.smartvisiondirect.com/inc.php?inc=contact It conitinues to report the error message above instead of

" Not Found

The requested URL /inc.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

in the link you provide i get 2 option the one you should use is to click on advanced

then you choose Proceed to www.smartvisiondirect.com (unsafe)

I do not get that link to proceed on the Mac osx version. I do get it on my Android Brave.

could you try to create new profile and see if it work or not?

I create a new profile and I got the same results. Has anyone tried this on a Mac OS.

do not you get proceed to (unsafe) behind the hide advanced button

The screen shot shows that I do not get proceed option. this is occurring in version Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (x86_64)
May-3-2021 for the mac

let me ask @Mattches from the team to help you with that

You mentioned 192.168.1.1 as the URL but in the screenshot you posted it displays 192.168.100.100

Is it the same error in both URLs?

2 Likes

nice catch @yubi :slight_smile:

I would also like to know the answer to @yubi’s question. I’ve reached out to @fanboynz to evaluate as well.

1 Like

https://www.ssllabs.com/ssltest/analyze.html?d=smartvisiondirect.com

smartvisiondirect.com has an untrusted cert.

Local ip’s (like routers, switches and nas’s) will have self-assigned certs, which will display the error message also.

1 Like