How to disable 'Your connection is not private'

Description of the issue:
Brave is my default browser. It is up-to-date.

At many sites that I visit (including https://community.brave.com) all I see is

Your connection is not private
Attackers might be trying to steal your information from www.community.brave.comcom (for example, passwords, messages, or credit cards). Learn more
NET::ERR_CERT_DATE_INVALID

When I click the “Advanced” button I see the following:

community.brave.com normally uses encryption to protect your information. When Brave tried to connect to community.brave.com this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be community.brave.com, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Brave stopped the connection before any data was exchanged.

You cannot visit community.brave.com right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

Actual Result (gifs and screenshots are welcome!):
There is no attack. Brave is faulty. When I use another browser (I am using Firefox right now to access community.brave.com), there is no problem.

Expected result:
I want to be able to access every web site I choose to visit. So, I have no interest in trying to fix this prohibition of Brave, I want to simply completely disable this nonsense feature. Make it go away. I have been using the web since the mid-90s. I don’t care if the site uses http or https. Please tell me how to kill this ‘feature.’ I want it dead. 100% gone. Please.

Reproduces how often:
This happens to about 1/5th of the sites I visit. It is making Brave.com almost unusable and may force me to switch to another browser.

Operating System and Brave Version(See the About Brave page in the main menu):
iMac 24-inch, early 2009
chip: 3.06 GHz Intel Core 2 Duo
memory: 4 GB 1067 MHz DDR3
graphics: ATI RAdeon HD 4850 512 MB

Brave is up to date
Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (x86_64)

Additional Information:
At another thread there was the suggestion to ENABLE:

Allow invalid certificates for resources loaded from localhost.
Allows requests to localhost over HTTPS even when an invalid certificate is presented. – Mac, Windows, Linux, Chrome OS, Android

#allow-insecure-localhost

That is now enabled, and it does not fix the problem.

1 Like

Does the same issue occur in Chrome also?

I would go through all the mac updates, update everything.

1 Like

I have exactly the same issue. Plus Brave stopped offering ads to click on, and everything I earned in September disappeared.

Funnily enough, the kids’ computer is perfectly fine, working as always, the sites and the ads - the lot!

I’m not a computer geek, so for most things I would need clear instructions for, but I’m not afraid of trying, so please, if anyone knows what to do with this, I’d too be very grateful!

1 Like

Make sure to also follow the next link from there, it is to another thread that has a workaround.

1 Like

I don’t know. I trashed Chrome after I transitioned to Brave

1 Like

JimB1 I have reviewed the links you offered, but I don’t see an obvious solution. One suggestion led to some padlocked certificates in some root section of my computer, but were not part of Brave. They are locked so couldn’t access them anyhow. I don’t want to risk breaking my computer, I just want this browser to show me the web sites I choose to visit, and that I know are accessible because when I use Firefox there is no problem. At the moment, the easiest solution is to stop using Brave. It is Brave that is broken, not my computer. Anyhow, I really don’t want an education on certificates (whatever they are) I just want a fast fix for this browser, and clear step by step instructions. Thanks

1 Like

The most direct solution that may also work for macOS (even though the video is of Windows) I think I can provide is from another user in that same thread:

"It is Brave that is broken, not my computer. " This is simply not correct. If your operating system is not maintained and that leads to not updating certificates (I understand you aren’t familiar with them, but the fact must be accepted that they exist and are important) then that is the root cause of your issue. That’s why others have suggested updating your operating system if possible, although for some systems that may not be possible.

1 Like

I followed the instructions in this video, and it seems to have solved the problem. It was only an hour ago, so I consider this a preliminary report. I will let you know if I encounter any further problems.